Closed Bug 353738 Opened 16 years ago Closed 16 years ago

[Meta] 0.8 Release

Categories

(Core Graveyard :: XForms, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: surkov, Assigned: aaronr)

References

Details

Attachments

(3 files, 1 obsolete file)

 
Depends on: 356498
Depends on: 356499
Depends on: 356508
Depends on: 334937
Depends on: 339198
Depends on: 356515
Depends on: 312956
Depends on: 316353, 353880, 356790
Depends on: 357569, 357652, 357716
Depends on: 361094, 362308, 366743, 368248
Depends on: 368627
Depends on: 339827
Can we add bug 366878 to this list?
Depends on: 366878
Depends on: 372127
Depends on: 372197
Depends on: 372323
Depends on: 373953
Depends on: 350928
Depends on: 375320
Depends on: 375754
Depends on: 376217
Blocks: 376307
No longer depends on: 312956, 334937, 339198, 356508, 356515, 372127, 372197, 372323
Depends on: 376386
Attached patch first attempt (obsolete) — Splinter Review
This patch contains the fixes for:

bug 357652, bug 356498, bug 332083, bug 351067, bug 357716, bug 361814, bug 358712, bug 362310, bug 348053, bug 361366, bug 350067, bug 360974, bug 356190, bug 367256, bug 353880, bug 353677, bug 367719, bug 363516, bug 366743, bug 368627 , bug 349644, bug -, bug part, bug 339286, bug 365907, bug 340088, bug 339827, bug 357901, bug 309442, bug 371285, bug 371607, bug 340995, bug 368248, bug 347563, bug 373061, bug 362308, bug 374274, bug 361094, bug 375320, bug 357569, bug 375546, bug 375754, bug 374994, bug 375983, bug 375986, bug 376386, bug 376385, bug 366878, bug 350928, bug 376217

Fixes contained in this patch that don't seem to work due to differences between trunk and branch.  These might need to be reworked.  Don't know if we'll hold up 0.8 for some/all of these or not:

bug 347327, bug 360188, bug 361997, bug 370551, bug 372736, bug 372737, bug 372739
Depends on: 376931
Attached patch patch1Splinter Review
Replaces first patch.  Actually checked this one in.  Includes all the bugs from the previous patch plus:

bug 376931, bug 376958, bug 376989, and bug 360188.  Backed out bug 339827 and reworked bug 374994.

Checked into branch.
Assignee: xforms → aaronr
Attachment #260924 - Attachment is obsolete: true
Status: NEW → ASSIGNED
checked in the dayTimeDuration patch for bug 372739 to 1.8 branch, so that will be in 0.8, too.
Attachment #261443 - Attachment is patch: true
Attachment #261443 - Attachment mime type: application/octet-stream → text/plain
Attached patch patch 2Splinter Review
includes the fixes for bug 377298, bug 377702, bug 377867, bug 377874, bug 377962, bug 377878, bug 378551
(In reply to comment #6)
> Created an attachment (id=262708) [details]
> patch 2
> 
> includes the fixes for bug 377298, bug 377702, bug 377867, bug 377874, bug
> 377962, bug 377878, bug 378551
> 

checked into branches
Depends on: 377880
checked in bug 361501 (got approval for transformiix changes) and bug 378702 (completed fix, fixed regression, of bug 377878) to branches.
checked in bug 377888.  Now we just need bug 377880 (waiting for review) and bug 342857 (waiting for approval).  Since 1.8 and 1.8.0 are about to freeze, bug 342857 might have to slip to 0.9 if approval isn't quick enough.  Unfortunately sicking is out until Monday.
oops, forgot to close.
Status: ASSIGNED → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.