bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

UIEvent::detail not implemented

VERIFIED FIXED

Status

()

Core
DOM: Events
P3
normal
VERIFIED FIXED
19 years ago
17 years ago

People

(Reporter: Joe Hewitt, Assigned: joki (gone))

Tracking

Trunk
x86
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
The DOM Level 2 standard defines the detail attribute on the UIEvent interface 
for determining some abstract notion of detail about an event.

MouseEvent inherits from UIEvent, and should use detail to express 
the "clickCount" of the event.  Currently, Mozilla uses the non-standard 
clickCount attribute to determine this information.  When I try to access 
detail, not only does it not return a value, but it actually generates a 
javascript error (of which type I can't see due to the lack of a js console).
(Reporter)

Comment 1

19 years ago
Created attachment 7439 [details]
test case
DOM Level 2 events, over to you joki...
Assignee: jst → joki
The JS error is an NS_ERROR_NOT_IMPLEMENTED.  Oops...  Confirming bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

18 years ago
Fixed
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
Component: DOM Level 2 → DOM Events

Comment 5

17 years ago
QA Contact Update
QA Contact: vidur → vladimire

Updated

17 years ago
Status: RESOLVED → VERIFIED

Comment 6

17 years ago
verifying build 2001-06-11-0.9.1
You need to log in before you can comment on or make changes to this bug.