Closed Bug 353831 Opened 14 years ago Closed 13 years ago

Deleting an IMAP message, then choosing Undo, doesn't bring the message back

Categories

(Thunderbird :: Mail Window Front End, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INCOMPLETE

People

(Reporter: sheppy, Unassigned)

Details

(Whiteboard: closeme 01/20)

This seems to be 100% repeatable on my system.  If I select a message in the message list, press the delete key to move it to the trash, then choose Undo, nothing happens.
after you delete a message, does the edit menu have an enabled "undo delete" item?
Hm.  Of course when I went to try it just now, it actually worked correctly.  This is the first time that I've been able to undo deleting a message.  I'll poke at this some more.
yeah, this happened to both me and Seth S as well. Is this your mozilla.com IMAP account?

Do you not shutdown TB very often? Shutting down and restarting fixes this, I'm pretty sure.
It seems to happen on all my accounts, but you may be right about restarting TB making the problem go away temporarily -- I just rebooted my Mac last night before turning in, after installing the new AirPort update, so it's possible that cleared the problem out.  I'll keep an eye on it.
Eric, 
100% repeatable, i.e. never works?
still fail in version 2?

dupe: bug 344163?
anyone still see this?

WFM in 2.0 and trunk windows, and I can't quite imagine this would be Mac-only. And didn't find anything related that directly mentions undo, fixed or unfixed, except bug 346630 which is not well defined.

The only major issue I've encountered (in trunk anyway) is undo of a moved or deleted message leaving a copy in previous target or trash folder.
Assignee: mscott → nobody
Whiteboard: closeme 01/20
Resolving closeme bugs that did not have any useful information provided since the last comment. -> incomplete.

Please feel free to comment if the issue still occurs in the latest supported version 2.0.0.12 or trunk nightlies.

Filter on ENDEAVOURLANDSATNIGHT123
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.