Closed Bug 35396 Opened 20 years ago Closed 20 years ago

Progress dialog hangs after triggering lots of xpis on Mac

Categories

(Core Graveyard :: Installer: XPInstall Engine, defect, P3)

PowerPC
Mac System 9.x
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: depman1, Assigned: samir_bugzilla)

References

Details

(Whiteboard: [nsbeta2-])

Mac only. build 2000-04-10-08M15. intermittent. no discernable patterns.
1.Started with Mac reboot.
2.Then triggered a xpi. Press OK. 
3.Go down the acceptance test case menu one by one and trigger. Usually it took 
between 20-25 triggers. I have seen it hang on such files as a_adddelregfile, 
a_execute_mac, a_macpatch, a_winpatch.

4. After triggering each xpi, check the progress dialog ("Downloading").

Result: Progress dialog freezes. "Transferring data from jimbob" displayed in 
status message area. (looks like some event handling problem). One can click on 
Mozilla and trigger another xpi.
regression from PR1, must fix in PR2
Keywords: nsbeta2
Target Milestone: --- → M16
Putting on [nsbeta2+] radar for beta2 fix.
Whiteboard: [nsbeta2+]
reassigning to doug.  :-)
reassign bugs to dveditz...  :-)
Assignee: cathleen → dveditz
No user is going to do 20-25 installs per session, removing nsbeta2+ for 
reconsideration. I don't even have a Mac so reassigning to Samir
Assignee: dveditz → sgehani
Summary: Progress dialog hangs after triggering xpi on Mac → Progress dialog hangs after triggering lots of xpis on Mac
Whiteboard: [nsbeta2+]
Target Milestone: M16 → M17
Triggering is generally horked in any case.  Adding depdendency on bug 38989.
Status: NEW → ASSIGNED
Depends on: 38989
[nsbeta2-] since it is very low probability for users, as dveditz points out.
Whiteboard: [nsbeta2-]
don't think this is happening anymore. I triggered over 100 .xpis without any 
crashes or hangs.
Marking fixed based on QA's comments.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
verified.
Status: RESOLVED → VERIFIED
OS: Mac System 9.x
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.