Page not displayed when moving the tab while the page is loading

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
RESOLVED WORKSFORME
12 years ago
9 years ago

People

(Reporter: Frédéric Buclin, Unassigned)

Tracking

2.0 Branch
x86
Linux
Points:
---
Bug Flags:
blocking-firefox2 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
Click on a link, and decide to move the page/tab to another place (before the page has loaded). Be slow enough before releasing the tab so that the page has loaded completely. Then release the tab: the page isn't displayed!

If you clicked on a link and asked to open it in a new tab, then this tab remains empty (grey backround). If you wanted the link to be displayed in the same tab, then the content of the page doesn't change.

Interesting is that the source code is correct, i.e. it shows the loaded page.

We are four testers being able to reproduce the bug, all 4 are on Linux using Fx2 RC1.
(Reporter)

Comment 1

12 years ago
Having to wait for the page to be loaded before moving the tab is pretty annoying. Requesting blocking.
Flags: blocking-firefox2?
(Reporter)

Comment 2

12 years ago
ispiked wanted the UA of my browser:

Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.1) Gecko/20060923 BonEcho/2.0

Comment 3

12 years ago
To be clear, these are the steps I used to reproduce this bug:

1. Make sure tabs are set to open in the background.
2. Right click > Open Link in New Tab on a link.
3. Quickly start to drag the tab you're in.
4. Don't release the drag till the page you opened has loaded.
5. Switch to the newly opened tab.

The newly opened tab should have a gray background.

or...

1. Click on a link in a page and quickly start to drag the current tab.
2. Don't release till the page has "finished" loading (throbber has stopped).

The tab should have the opened link's address in the location bar, and title in the window's titlebar, but you should still see the contents of the page the link was opened from.

Interestingly, opening (or closing) the Find Bar makes the page that was opened appear.
Seems to be rarely/never reproducable other than on Linux.  On Linux, this might be another manifestation of the general DnD+event weirdness that's bitten us in the past.  Given the odd STR, and ways around it, not going to block at this time.
Flags: blocking-firefox2? → blocking-firefox2-
(Reporter)

Comment 5

9 years ago
I cannot reproduce with Fx3.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Target Milestone: Firefox 2 → ---
You need to log in before you can comment on or make changes to this bug.