Mycroft Project should be included as a pre-installed search engine plugin

VERIFIED WONTFIX

Status

()

--
enhancement
VERIFIED WONTFIX
12 years ago
10 years ago

People

(Reporter: I_am_RenegadeX, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20060918 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20060918 Firefox/2.0

As Mycroft is apparently 'the' premier Mozilla-approved place to get Search Engine Plugins for Firefox, it seems obvious (to me) to have Mycroft as a pre-installed Search Engine plugin - so that users can quickly and effortlessly find the additional Engines they wish to install.

Mycroft is surprisingly not even in the Top 25 plugins installed according to the site's latest stats. It is obvious that users aren't using their noggin and are accessing the site & finding their plugins the 'slow' way, which is kinda ironic as Search efficiency is the very purpose of the Search Bar!

I remember suggesting this in a couple of places previously - but if fell on deaf ears - and was therefore surprised not to see this filed as a [enh] Bug previously.

Reproducible: Always
(Reporter)

Updated

12 years ago
Summary: Mycroft plugin should be included as a pre-installed search engine plugin → Mycroft Project should be included as a pre-installed search engine plugin

Updated

12 years ago
Version: unspecified → Trunk
I vote NO.
I'm fairly sure I've seen a WONTFIX dupe of this, though maybe I'm thinking of a comment on a bug rather than an actual bug about it. Searching for search engines is rather confusing, and we already have a "Get more" link for people who are looking to get more engines. That link leads to a neater and more appealing page, in my opinion, and it also links to Mycroft in case people are looking for more specific search engines.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

12 years ago
^ Sorry Gavin, that's a very weak rationale for marking my suggestion a "WONTFIX".
But at least it was better than the simple and blunt "I vote NO" from Mats!

** 1. Gavin said: "Searching for search engines is rather confusing".
- a) I did not file this Bug on behalf of 'confused' users. Rather, I filed this Bug on behalf of users who already know what a great resource Mycroft is -- and who:
- will add the Mycroft Project search engine anyhow; or
- never thought (or will think) to do add it, but would certainly find its presence a time-saving and handy addition.

- b) There is absolutely no need for a user to be confused about finding & adding search engines. If users are confused, then we have to look at the reasons why this is so, and what could have been done/done better to prevent this from happening. The inclusion of a pre-installed Mycroft engine is inconsequential to any existing or future confusion.

** 2. Gavin said" "we already have a 'Get more' link for people who are looking to get more engines".
- So what? Who said that it has to be one or the other?
Besides.. where does "Get more.." take users? Answer: to an AMO page with a paltry 22 'select' search engines (vs Mycroft's 8,950+ engines), a search box that *doesn't* search for search engine plugins, a weak reference to the goldmine that is Mycroft *buried* in a mess near the bottom of the page, no reference to any Help pages/walkthroughs (for those who are confused already), and also no info on or link to info on creating custom engines. (For all I know, there are great plans in the works to be unveiled upon FF2.0's release, but as an FYI: searchplugins.net has a handy custom generator, and Mycroft has always had one, but it's overly-complicated). Refer back to "1b)" above - need any more clues??

** 3. Gavin wrote: "That link [to AMO] leads to a neater and more appealing page, in my opinion".
-  Your opinion. My opinion - they both could use some layout & content work, and perhaps the 2 projects would be best off merged.

** 4. Gavin wrote: ".. it also links to Mycroft in case people are looking for more specific search engines"
- And there's nothing wrong with that. See #2, above. But I will repeat: "Search efficiency is the very purpose of the Search Bar!"

Should a user wish to search Mycroft for a new engine, using the "Get more.." route - to even get to the point where a user is able to enter their query, he or she is required to perform SIX clicks.. AND wait for 1 dialog box and 2 unnecessary webpages to load! Not only could you not possibly be more *inefficient* than that, but searching using a query box on a webpage is archaic! Subsequent engines searches on Mycroft require 2 more clicks including 1 webpage load wait. This is know as 'ironic hypocrisy' and also, "setting a bad example". Using a pre-installed Mycroft Project plugin, it's a quick 2 clicks to select Mycroft from the dropdown and you're ready to type & Search, and subsequent searches are instantly 1-click away (just focus the search box).

This Bug should be Reopened and Fixed asap.

Comment 4

10 years ago
Almost nothing has changed since 2006. The "Get more" link still takes the user to a page, which is clean, but is completely unrelated it searches for search-related add-ons. The only useful page for search plugins is Mycroft. And now that clean page doesn't even have a link to Mycroft.

Mycroft is the first search plugin i add when i install Firefox, but i am a power user and i know about Mycroft's existence. What about all the other users?
Steven, is it a dupe of bug 426234? Several other bugs with the same proposal were duped against this one.

Comment 6

10 years ago
(In reply to comment #5)
> Steven, is it a dupe of bug 426234? Several other bugs with the same proposal
> were duped against this one.

Looks enough like a dupe to me.

This is just the first one that came up when i searched for Mycroft :)
Uh, bug 426234 was about adding it back to the landing page on AMO, and this bug seems to (only) be about it being pre-installed in the client; or am I missing something?

Comment 8

10 years ago
(In reply to comment #7)
> Uh, bug 426234 was about adding it back to the landing page on AMO, and this
> bug seems to (only) be about it being pre-installed in the client; or am I
> missing something?

Ehh... my bad. You're right, actually. It's a different issue.

I find that AMO page useless and misleading, in any case; and i find Mycroft very useful.

The only imaginable problem with the Mycroft site is its name; i understand its meaning, but not every user will understand the connection. But this is a minor issue, as Mycroft is clearly useful for finding search plugins.
(In reply to comment #7)
> Uh, bug 426234 was about adding it back to the landing page on AMO, and this
> bug seems to (only) be about it being pre-installed in the client; or am I
> missing something?

Probably we should let it be on its own. You are right. CC'ing Seth and Stas to let them know of this bug. But at least the definition of the pre-installed search engine providers is done by the localization teams. The list differs per locale and only the most common ones are included. Seth or Stas, could you please verify the wontfix state?

Comment 10

10 years ago
(In reply to comment #9)
> But at least the definition of the pre-installed
> search engine providers is done by the localization teams. The list differs per
> locale and only the most common ones are included. Seth or Stas, could you
> please verify the wontfix state?

Verify WONTFIX.  Search engines that make it into localized versions of Firefox follow a specific process described here:  https://wiki.mozilla.org/Firefox_web_services_guidelines

Comment 11

10 years ago
Why does it have to be decided by localization teams? It is a meta thing, useful for everybody. Mycroft is very international.
Status: RESOLVED → VERIFIED

Comment 12

10 years ago
(In reply to comment #11)
> Why does it have to be decided by localization teams? It is a meta thing,
> useful for everybody. Mycroft is very international.

If localizers choose to include Mycroft, they suggest it and we consider it.  However, this bug (at least comment #3) seems to be about the usability of the current "Manage Search Engines..." process I find by clicking on the drop down arrow in the en-US build.  I don't think it is up to me to comment on user experience of adding more search engines, but from an l10n perspective, we'll let the localizers continue to make recommendations that they feel are best for their users.

Comment 13

10 years ago
(In reply to comment #12)
> (In reply to comment #11)
> > Why does it have to be decided by localization teams? It is a meta thing,
> > useful for everybody. Mycroft is very international.
> 
> If localizers choose to include Mycroft, they suggest it and we consider it. 

Why are localizers so important for this matter? What i am trying to say is that it is relevant for all Mozilla users, no matter what language they speak.
(In reply to comment #12)
> arrow in the en-US build.  I don't think it is up to me to comment on user
> experience of adding more search engines, but from an l10n perspective, we'll
> let the localizers continue to make recommendations that they feel are best for
> their users.

Alex could you give a statement from the UX side?

Comment 15

10 years ago
(In reply to comment #13)
> Why are localizers so important for this matter? What i am trying to say is
> that it is relevant for all Mozilla users, no matter what language they speak.

We (l10n community) doesn't determine the en-US default search plugins.  However, localizers choose whatever search engines they want, which can override any of the defaults.  Have you had a chance to read the documentation I provided?  That should be helpful for you to understand why we defer directly to localizers.

Comment 16

10 years ago
I read it and i didn't understand how l10n people are related to this bug, as it has nothing to do with l10n. It is natural that l10n people will decide about relevant local search plugins. But this is a meta search plugin, which searches for other search plugins, and thus it is relevant for everybody.

This search plugin should be included in all localized versions of Firefox. Its title can be localized; In English it should be "Get more search engines".

At the very least, the page that is presented to the user when he clicks the "Get more search engines" link in Manage Search Engine List dialog should be strongly improved, as the current one is not so helpful. But the easiest way to solve this would be to simply add Mycroft (under a different title) to the search box.
>Alex could you give a statement from the UX side?

I agree with Gavin's comment #2 back in 2006

Comment 18

10 years ago
(In reply to comment #17)
> I agree with Gavin's comment #2 back in 2006

Try using that "neat" page to search for a *search plugin* that searches for words in these online dictionaries:

* LEO (German)
* RAE (Spanish)
* Morfix (Hebrew)

The "neat" page will find *addons*, not search plugins. Addons have nothing to do with the search box.

Where are users supposed to find search plugins if they have never heard about Mycroft?
You need to log in before you can comment on or make changes to this bug.