crash when cancelling Open File dialog

VERIFIED DUPLICATE of bug 34651

Status

SeaMonkey
UI Design
P3
critical
VERIFIED DUPLICATE of bug 34651
18 years ago
13 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: Bill Law)

Tracking

({crash, pp, regression})

Trunk
PowerPC
Mac System 9.x
crash, pp, regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
dang, i coulda sworn this might've cropped up recently, but i cannot find it in
bugzilla. apologies for the dup...

found using the opt comm bits on Mac, 2000.04.10.10. doesn't crash on linux or
winNT.

1. open Open File dialog (native file picker), eg, File > Open File.
2. click Cancel button.

result: seamonkey crashes.

talkback incident #8405602:
http://cyclone/reports/incidenttemplate.CFM?reportID=124&style=0&tc=80&cp=1&ck1=SUser+email+address&cd1=%25sairuh%40netscape%2Ecom%25&co1=like&bbid=8405602


 Call Stack:    (Signature = .__ptr_glue 957140b4) 
     
  .__ptr_glue 
                                                
     
  nsFilePicker::GetFileURL() 
                                               [nsFilePicker.cpp, line 508]
     
  CODE.10 
                                                
     
  XPTC_InvokeByIndex() 
                                               [xptcinvoke_mac.cpp, line 129]
     
  nsXPCWrappedNativeClass::CallWrappedMethod() 
                                               [xpcwrappednativeclass.cpp, line
892]
     
  WrappedNative_GetProperty() 
                                               [xpcwrappednativejsops.cpp, line
244]
     
  js_Interpret() 
                                               [jsinterp.c, line 2322]
     
  js_Invoke() 
                                               [jsinterp.c, line 702]
     
  js_InternalInvoke() 
                                               [jsinterp.c, line 774]
     
  JS_CallFunctionValue() 
                                               [jsapi.c, line 2792]
     
  DOM_DLL + 0x7754 (0x06842204) 
                                                
     
  DOM_DLL + 0x5f890 (0x0689a340) 
                                                
     
  nsEventListenerManager::HandleEventSubType() 
                                               [nsEventListenerManager.cpp, line
703]
     
  nsEventListenerManager::HandleEvent() 
                                               [nsEventListenerManager.cpp, line
1474]
     
  nsXULElement::HandleDOMEvent() 
                                               [nsXULElement.cpp, line 3294]
(Reporter)

Updated

18 years ago
Keywords: crash, pp, regression
QA Contact: paulmac → sairuh
(Assignee)

Comment 1

18 years ago
I think this is a dup of 34651 (although a different symptom).  Pavlov checked 
in a fix for that one today so this one should be fixed, also.  If not, reopen 
(and assign to him, not me :-).

*** This bug has been marked as a duplicate of 34651 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

18 years ago
a-yup, now works today...
Status: RESOLVED → VERIFIED

Updated

13 years ago
OS: Mac System 9.x
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.