Closed Bug 354062 Opened 13 years ago Closed 13 years ago

crash when entering text into location bar

Categories

(Camino Graveyard :: Location Bar & Autocomplete, defect, blocker)

PowerPC
macOS
defect
Not set
blocker

Tracking

(Not tracked)

RESOLVED FIXED
Camino1.5

People

(Reporter: peeja, Assigned: hwaara)

References

Details

(Keywords: crash, fixed1.8.1)

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1) Gecko/20060924 Camino/1.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1) Gecko/20060924 Camino/1.0+

On entering text into the location bar, Camino crashes.  A clean profile doesn't fix it.  I can type multiple characters before the crash, so perhaps this is an autocomplete problem.

Reproducible: Always

Steps to Reproduce:
1. Open Camino.
2. Type anything into the location bar.
Exploring further, deleting characters triggers it as well, so it's probably not autocomplete.
Can you attach crash logs here (and/or link to talkback reports)?
Attached file Camino.crash.log (obsolete) —
Crash log.
Can someone else try to get a stack too?

The stack looks like something that would happen when the loading status of a page changed (e.g., it just finished, or is reloaded or something).
Hmm, I downloaded the latest branch-nightly and trunk-nightly and couldn't reproduce in either, doing some simple surfing while autocompleting a few common URLs.
Attached file The *real* crash log
Will the real Camino.crash.log please stand up?  Thank you.

This exact crash is from a trunk nightly, but the log looks the same as the branch nightly I first found the bug with.  The behavior is the same.
Attachment #239944 - Attachment is obsolete: true
Confirming on 10.3.9; http://pastebin.mozilla.org/602 (identical to peeja's afaict)
Status: UNCONFIRMED → NEW
Ever confirmed: true
This is really a blocker on the branch; fortunately, the patch in bug 354034 seems to fix it.
Severity: critical → blocker
Depends on: 354034
Target Milestone: --- → Camino1.1
Assignee: nobody → hwaara
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Keywords: fixed1.8.1
You need to log in before you can comment on or make changes to this bug.