From Win 98, update.html installs and appears to try to extract again

VERIFIED WORKSFORME

Status

Core Graveyard
Installer: XPInstall Engine
P3
normal
VERIFIED WORKSFORME
18 years ago
3 years ago

People

(Reporter: Jimmy Lee, Assigned: dveditz)

Tracking

({pp})

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build: 2000-04-10-09-M15(WIN)

1. From Windows 98, Install 
ftp://sweetlou/products/client/seamonkey/windows/32bit/x86/2000-04-10-09-M15/
2. Launch 2000-04-10-09-M15, and go to 
ftp://sweetlou/products/client/seamonkey/windows/32bit/x86/2000-04-09-09-M15/upd
ate.html and click Launch XPInstall button with defaults (all checkboxed)

RESULT:
Update appears to install correctly.  The install.log shows all the xpis 
triggered.  At the end, it shows all the xpis trying to be read again, but 
returning error -207.  See end of this bug report.  No problem was observed 
under Windows NT.

EXPECTED RESULT:
Installation completes.  install.log does not show additional attempts to read 
xpis again.

NOTE:
This behavior is not observed by triggering a single xpi.  Also, this dilemma 
was not reproduced with a multitriggering test case.

END OF install.log:
-------------------------------------------------------------------------------
ftp://sweetlou/products/client/seamonkey/windows/32bit/x86/2000-04-09-09-M15/xpi
/core.xpi  --  04/10/2000 17:00:27
-------------------------------------------------------------------------------


     Install **FAILED** with error -207
     Finished Installation  04/10/2000 17:00:27

-------------------------------------------------------------------------------
ftp://sweetlou/products/client/seamonkey/windows/32bit/x86/2000-04-09-09-M15/xpi
/browser.xpi  --  04/10/2000 17:00:28
-------------------------------------------------------------------------------


     Install **FAILED** with error -207
     Finished Installation  04/10/2000 17:00:28

-------------------------------------------------------------------------------
ftp://sweetlou/products/client/seamonkey/windows/32bit/x86/2000-04-09-09-M15/xpi
/mail.xpi  --  04/10/2000 17:00:28
-------------------------------------------------------------------------------


     Install **FAILED** with error -207
     Finished Installation  04/10/2000 17:00:28

-------------------------------------------------------------------------------
ftp://sweetlou/products/client/seamonkey/windows/32bit/x86/2000-04-09-09-M15/xpi
/fullcircle.xpi  --  04/10/2000 17:00:28
-------------------------------------------------------------------------------


     Install **FAILED** with error -207
     Finished Installation  04/10/2000 17:00:28

-------------------------------------------------------------------------------
ftp://sweetlou/products/client/seamonkey/windows/32bit/x86/2000-04-09-09-M15/xpi
/spellchecker.xpi  --  04/10/2000 17:00:28
-------------------------------------------------------------------------------


     Install **FAILED** with error -207
     Finished Installation  04/10/2000 17:00:28
(Reporter)

Comment 1

18 years ago
Adding pp to Keywords.
Keywords: pp

Comment 2

18 years ago
need help verify if still a valid bug
Assignee: cathleen → jimmylee
(Reporter)

Comment 3

18 years ago
Build: 2000-05-08-09-M16(WIN)

From Windows NT, I can successfully update to Build 5/5/00.  From Windows 98, 
I am unable to verify because the browser crashes when attempting to open 
ftp://sweetlou/products/client/seamonkey/windows/32bit/x86/2000-05-05-13-M16/upd
ate.html.
Assignee: jimmylee → cathleen
Parcelling out Cathleen's bugs
Assignee: cathleen → dveditz

Comment 5

18 years ago
doesn't happen anymore.
resolved based on QA comments.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

18 years ago
Build: 2000-08-13-09-M18(WIN)

Marking Verified.  No longer a problem.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.