Hangs selecting Message in thread pane after form submit

VERIFIED FIXED in M16

Status

SeaMonkey
MailNews: Message Display
P3
critical
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Peter Trudelle, Assigned: Scott MacGregor)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dogfood+] still trying to trigger the problem.)

(Reporter)

Description

18 years ago
I haven't really tried this again to get minimal steps to reproduce, but since
it has happened to me 3 times in the last 2 hours...

Using today's NS6 verification build (41009)on Win98:
Open NS 6 with -mailnews option.
Log into IMAP server (may not make any difference vs POP)
Sort messages by sender.
select first bugzilla notification (of many!)
Click on the link inside it to open the bug in Nav window.
Update the bug, commit.
While form is submitting & notification loading, switch back to mail window.
click on the next message in thread pane.
Expected result: Messenger loads message, Nav finishes loading page.
Actual result: Both windows freeze, show no activity, and are completely
unresponsive.
(Reporter)

Comment 1

18 years ago
changing to critical severity, putting on dogfood radar.
Severity: normal → critical
Keywords: dogfood
OS: other → Windows 98
(Assignee)

Comment 2

18 years ago
I'm trying this out right now.

Comment 3

18 years ago
I am seeing something similar, started seeing on 4/10 builds on win98, but 
hadn't used a trunk build in a while.

My hang is happening right when I click on links in the message pane. Seems to 
happen randomly, no crash, just a hang, but does seem to happen at least 20% of 
the time.

Comment 4

18 years ago
Peter, still trying to reproduce your problem.  What happens if you have two 
browser windows up and in one window, the bug form is still committing and then 
in the other browser window, you try to open another URL?

Comment 5

18 years ago
Updating this bug to test this bug.
(Reporter)

Comment 6

18 years ago
Let's see, trying...
(Reporter)

Comment 7

18 years ago
...no, they both load as expected. I'm using today's build, so I'll try to
reproduce the original problem again...

Comment 8

18 years ago
PDT agrees this is dogfood
Whiteboard: [dogfood+]

Comment 9

18 years ago
Scott, can you look into this further?  
Assignee: selmer → mscott
Target Milestone: --- → M16
(Assignee)

Comment 10

18 years ago
I'm still trying to reproduce this on my machine. I haven't gotten it to happen
yet. I'm hoping it isn't a Windows 98 specific bug =(.


Status: NEW → ASSIGNED
Whiteboard: [dogfood+] → [dogfood+] still trying to trigger the problem.
(Reporter)

Comment 11

18 years ago
I haven't seen this in a while either, even on Win98. I hope I haven't just
conditioned myself to avoid it.
(Assignee)

Comment 12

18 years ago
Peter, I'm going to go ahead and mark this as fixed as neither you nor I can see
to reproduce it anymore. Please feel free to re-open if you see it again.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 13

18 years ago
Laurel - can you help me to verify? Thanks.

Updated

18 years ago
QA Contact: lchiang → laurel

Comment 14

18 years ago
I can't reproduce this using 2000-05-23-10 NT 4.0.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.