If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[FIX] position:absolute is broken

VERIFIED FIXED in mozilla1.9alpha1

Status

()

Core
Layout
P1
blocker
VERIFIED FIXED
11 years ago
11 years ago

People

(Reporter: Peter6, Assigned: bz)

Tracking

(4 keywords)

Trunk
mozilla1.9alpha1
regression, testcase, verified1.8.0.9, verified1.8.1.1
Points:
---
Bug Flags:
blocking1.8.1.1 +
blocking1.8.0.9 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060924 Minefield/3.0a1 ID:2006092421 [cairo]

repro:

open gmail and stare at a white screen
(visable on many sites)
*** Bug 354088 has been marked as a duplicate of this bug. ***
Blocks: 330909

Comment 2

11 years ago
Also happens here on OS X.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060925 Minefield/3.0a1
(Reporter)

Updated

11 years ago
OS: Windows 2000 → All
Hardware: PC → All
Created attachment 240024 [details] [diff] [review]
Fix
Assignee: nobody → bzbarsky
Status: NEW → ASSIGNED
Attachment #240024 - Flags: superreview?(roc)
Attachment #240024 - Flags: review?(roc)
This is what I get for testing changes in my local builds.  :(
Priority: -- → P1
Summary: position:absolute is broken → [FIX] position:absolute is broken
Target Milestone: --- → mozilla1.9alpha
Created attachment 240028 [details] [diff] [review]
Include the header too
Attachment #240024 - Attachment is obsolete: true
Attachment #240028 - Flags: superreview?(roc)
Attachment #240028 - Flags: review?(roc)
Attachment #240024 - Flags: superreview?(roc)
Attachment #240024 - Flags: review?(roc)
Attachment #240028 - Flags: superreview?(roc)
Attachment #240028 - Flags: superreview+
Attachment #240028 - Flags: review?(roc)
Attachment #240028 - Flags: review+
Fixed on trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Comment on attachment 240028 [details] [diff] [review]
Include the header too

If we decide to take bug 330909 for a release, we need to take this too.
Attachment #240028 - Flags: approval1.8.0.8?
Flags: blocking1.8.1.1?
*** Bug 354202 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 9

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060925 Minefield/3.0a1 ID:2006092520 [cairo]

VERIFIED/FIXED for win32
Attachment #240028 - Flags: approval1.8.0.9?
Attachment #240028 - Flags: approval1.8.0.8?
Attachment #240028 - Flags: approval1.8.0.8-
*** Bug 354382 has been marked as a duplicate of this bug. ***
Flags: blocking1.8.0.9?
Flags: blocking1.8.1.1?
Flags: blocking1.8.1.1+
Flags: blocking1.8.0.9?
Flags: blocking1.8.0.9+
Comment on attachment 240028 [details] [diff] [review]
Include the header too

Approved for 1.8.0/1.8 branches, a=dveditz for drivers
Attachment #240028 - Flags: approval1.8.1.1+
Attachment #240028 - Flags: approval1.8.0.9?
Attachment #240028 - Flags: approval1.8.0.9+

Comment 12

11 years ago
Boris could you please fix this together with bug 330909 on branches, I wouldn't like to checkin bug 330909 without the patch from this bug.
Yeah, once the 1.8.0 branch opens.
Created attachment 244952 [details] [diff] [review]
Branch version
Fixed for 1.8.1 and 1.8.0.9
Keywords: fixed1.8.0.9, fixed1.8.1
I meant 1.8.1.1.
Keywords: fixed1.8.1 → fixed1.8.1.1

Comment 17

11 years ago
Martijn and I verified bug 330909, but is there any easy way to test this fix?  If anyone has a testcase, please share.
Whiteboard: [need testcase]
This patch basically should have been part of the patch for bug bug 330909.
It's not possible to verify this for branch (unless by code inspection), it was a trunk regression that was caused by the patch for bug bug 330909.
(Reporter)

Comment 19

11 years ago
Created attachment 246863 [details]
testcase

the yellow square should be 100px from the top and 100px from the left

Comment 20

11 years ago
v.fixed on Trunk, as well as 1.8.0 and 1.8.1 branches, with Peter's testcase.  Yellow square's absolute position looks correct, so whatever was fixed for the Trunk did not introduce any regression on the branches for this testcase.
Status: RESOLVED → VERIFIED
Keywords: fixed1.8.0.9, fixed1.8.1.1 → verified1.8.0.9, verified1.8.1.1
(Reporter)

Updated

11 years ago
Keywords: testcase
Whiteboard: [need testcase]
You need to log in before you can comment on or make changes to this bug.