errors not displayed in XMLHttpRequest callback functions

RESOLVED INVALID

Status

Toolkit Graveyard
Error Console
--
major
RESOLVED INVALID
12 years ago
2 years ago

People

(Reporter: Michael Newton, Unassigned)

Tracking

({testcase})

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060913 BonEcho/2.0b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060913 BonEcho/2.0b2

Testcase will be attached momentarily.  I'm using the Yahoo UI library to perform an XMLHttpRequest call.  When completed successfully, a callback function is invoked.  No errors are reported in the console for this callback function.  Tested in 1.5.07 and the current nightly of 2.0

Reproducible: Always

Steps to Reproduce:
1. Load the attached testcase
2. Click the indicated area
3. Look at the error console

Actual Results:  
No errors reported

Expected Results:  
Should be several fatal errors.
(Reporter)

Comment 1

12 years ago
Created attachment 240025 [details]
testcase
(Reporter)

Updated

12 years ago
Keywords: testcase

Comment 2

12 years ago
This happens because Yahoo's libraries uses try..catch to intercept all errors in your callback function. Not a Firefox bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
(Assignee)

Updated

2 years ago
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.