Mail download hang/failure with specific attachment types

RESOLVED WORKSFORME

Status

Thunderbird
General
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: Rob, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2009-07-09)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

When downloading mail from a Microsoft Exchange server, Thunderbird will fail to download messages containing certain types of attachments.  The behavior exhibited, is that the mail download proceeds normally until an e-mail with one of these attachment types is reached.  Thunderbird then spends a long time trying to download that e-mail before eventually giving up on the entire mail download operation.  No notice of total e-mails downloaded is given.  I have observed the following actions from various attempts to get aroung this problem:
1) Attempting to restart the download will result in nothing happening.
2) All mail deleted when Thunderbird is configured to delete the mail from the server doesn't get deleted.  In fact, Thunderbird will re-d/l the mail and mark it as new but not notify the user.
3) Aborting the downloading while in this state and then re-starting the download seems to make Thunderbird forget which mail it has downloaded in the past so it downloads everything in the mailbox (even if it's been downloaded before) up to the mail that causes the problem, which will still cause the failure/hang scenario.
4) Deleting the attachment in Outlook allows the e-mail to be downloaded successfully.

I have witnessed this behavior with Oracle Workflows as attachments, but didn't get too many of them that I needed to worry about.  I have recently received some RTF documents (saved in Microsoft Word) that cause the same behavior.  The RTF documents are about 12K in size and contain only text.

This issue seems to have existed for quite some time as I have seen it from Thunderbird 1.0 to the current 1.0.7 release, on Windows 2000 (SP3 or SPR4) and WindowsXP SP1.

Reproducible: Always

Steps to Reproduce:
1.Create an RTF file of about 12K containing text.
2.Send to a user who retrieves e-mail from a Microsoft Exchange server
3.Try to download the e-mail using Thunderbird.

Actual Results:  
Thunderbird will attempt to download the e-mail, but after a long time fail silently.

Expected Results:  
I would expect the e-mail to be downloaded as any other e-mail would be.
(Reporter)

Comment 1

11 years ago
Created attachment 240034 [details]
When this file is an attachment in e-mail, Thunderbird will fail to download it.

Comment 2

11 years ago
WFM, I had no problem receiving it (attachment 240034 [details]) via Exchange. Tested on 1.5.0.7.
(Reporter)

Comment 3

11 years ago
What version of Exchange are you connecting to?  I am connecting to an Exchange 2003 Server, but I don't know if that makes a difference.  There are several people where I work that have this problem, and I have just re-tried the test with a fresh profile with 1.5.0.7 (20060909).

Any suggestions for additional testing to try to isolate the issue?

Comment 4

11 years ago
The server say it is: Microsoft Exchange Server 2003 POP3 server version 6.5.7638.1 

A pop protocol log might shed some light on the what's going on..
http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#pop

There isn't any antivirus/firewall interfering?
(Reporter)

Comment 5

11 years ago
I am still seeing this issue on Thunderbird 2.0.0.6 with some files (mostly RTFs).  I thought maybe virus scanner was the problem, but I disabled that and it didn't help.  Even more puzzling is that some RTF files seem to download ok.

I tried to create a log using the above instructions, but for some reason it always generated a file with 0 bytes and never filled it with anything.
(In reply to comment #5)
> but for some reason it always generated a file with 0 bytes and never filled it with anything.

Did you terminate Thunderbird before try to save log file?
Have you read next paragraph in the document?
> For IMAP, POP, NNTP, or SMTP, replace protocol with IMAP, POP3, NNTP, or SMTP respectively.
By the way, attach log file to this bug(text/plain if size is accepted). Never paste to bug, please.

Updated

9 years ago
Assignee: mscott → nobody
Rob, any response to comment #6?
Whiteboard: closeme 2009-07-09
Closing Incomplete for lack of answers at 2009-07-09. 

Feel free to reopen if you can provide more information.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 9

9 years ago
I was never able to retrieve useful debugging information and unable to reproduce in an environment outside a specific work controlled one.  I'm ok with closing the bug.
Resolution: INCOMPLETE → FIXED
(In reply to comment #9)
> I was never able to retrieve useful debugging information and unable to
> reproduce in an environment outside a specific work controlled one.  I'm ok
> with closing the bug.

-> WFM. Fixed is used for bugs with known patches. https://bugzilla.mozilla.org/page.cgi?id=fields.html#resolution
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.