unable to bookmark a page (or bookmark group of tabs, or create a bookmark keyword search) (with --disable-places) with one of my profiles

RESOLVED INVALID

Status

()

Firefox
Bookmarks & History
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

 
unable to bookmark a page (with --disable-places)

this is with my debug, mac os x, trunk build:  Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a1) Gecko/20060924 Minefield/3.0a1

when I follow these steps:
http://litmus.mozilla.org/show_test.cgi?id=1263

when the dialog comes up, I get:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIRDFService.GetDataSource]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: chrome://browser/content/bookmarks/addBookmark2.js :: Startup :: line 107"  data: no]


when I attempt to add the bookmark, I get:

Error: [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsIRDFContainer.Init]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: chrome://browser/content/bookmarks/addBookmark2.js :: onOK :: line 162"  data: no]
Source File: chrome://browser/content/bookmarks/addBookmark2.js
Line: 162
Status: NEW → ASSIGNED
Blocks: 353571
additionally, I can't bookmark a group of tabs (see http://litmus.mozilla.org/show_test.cgi?id=1258)

I get the same errors in the console.
Summary: unable to bookmark a page (with --disable-places) → unable to bookmark a page (or group of tabs) (with --disable-places)
additionally, I can't create a bookmark keyword search (for similar reasons)

see http://litmus.mozilla.org/show_test.cgi?id=1788
Summary: unable to bookmark a page (or group of tabs) (with --disable-places) → unable to bookmark a page (or bookmark group of tabs, or create a bookmark keyword search) (with --disable-places)
from gdb:

###!!! ASSERTION: null ptr: 'aContainer != nsnull', file /Users/sspitzer/Desktop/trunk-no-places/mozilla/rdf/base/src/nsRDFContainer.cpp, line 160

we are calling RDFContainerImpl::Init() with null for the second arg:

RDFContainerImpl::Init(nsIRDFDataSource *aDataSource, nsIRDFResource *aContainer)
I've tried with a new profile, and I'm not seeing these problems, so something might be horked with my profile.
Summary: unable to bookmark a page (or bookmark group of tabs, or create a bookmark keyword search) (with --disable-places) → unable to bookmark a page (or bookmark group of tabs, or create a bookmark keyword search) (with --disable-places) with one of my profiles
invalid, but odd.

my profile had symbolic links pointing to a (no longer) existing tree:

lrwxrwxrwx    1 sspitzer  sspitzer       85 Jun 15 15:43 localstore.rdf -> /Users/sspitzer/Desktop/bonecho2/mozilla/browser/locales/en-US/profile/localstore.rdf
lrwxrwxrwx    1 sspitzer  sspitzer       88 Jun 15 15:43 mimeTypes.rdf -> /Users/sspitzer/Desktop/bonecho2/mozilla/browser/locales/en-US/profile/mac/mimeTypes.rdf
-rw-r--r--    1 sspitzer  sspitzer    26946 Sep 25 19:38 prefs.js
lrwxrwxrwx    1 sspitzer  sspitzer       81 Jun 15 15:43 search.rdf -> /Users/sspitzer/Desktop/bonecho2/mozilla/browser/locales/en-US/profile/search.rdf

FWIW, I don't remember making those sym links!

When those links point into a non-exist files and folders, that explains the weirdness.

additionally, since rdf:local-store could not be found, that explain this error:

Error: uncaught exception: [Exception... "Component returned failure code:
0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIRDFService.GetDataSource]"  nsresult:
"0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame ::
chrome://browser/content/bookmarks/addBookmark2.js :: Startup :: line 107" 
data: no]
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
That sounds like bug 299149.
gavin, you rule.

Comment 9

11 years ago
*** Bug 362834 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.