If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

RFE: optional up button to chop off last part of URL

VERIFIED DUPLICATE of bug 33684

Status

()

Core
Networking
P3
enhancement
VERIFIED DUPLICATE of bug 33684
18 years ago
12 years ago

People

(Reporter: Jesse Ruderman, Assigned: don)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
RFE for an "up" button that chops off the last part of the URL.  It would 
probably be off by default.  

The main reason I'm posting this as a browser RFE instead of asking skin 
developers to do it (aside from the fact that i'm a bugzilla-vote whore) is 
that there should be standard code inside mozilla that the skins can call.  
There's no point in each skin developer creating the functionality separately, 
especially since they would probably each do if differently.

Potential problems:
- How would it handle a site where /foo/ redirects to /foo/index.html?


See also the following slashdot comment and its replies: 

http://slashdot.org/comments.pl?sid=00/04/08/1110208&threshold=-1&cid=148
(more permanent url) http://slashdot.org/articles/00/04/08/1110208.shtml#148
(Reporter)

Comment 1

18 years ago
A "top" button that acts like an href to / would be nice as well.

Comment 2

18 years ago
cool idea, but not really a networking thing -> don would know...
Assignee: gagan → don

Comment 3

18 years ago
The 'up' and 'top' buttons could be combined into one. Cf. the 'back' button.
You click once to go up one level, or there is a drop-down box which can take
you all the way to the top.

Nifty way to do directory browsing too. Gosh, it would be just like... uh...
windows explorer.

Comment 4

18 years ago
this is a duplicate of 
<a href="http://bugzilla.mozilla.org/show_bug.cgi?id=33684">bug 33684</a>, 
which has had some interesting discussions.
(Reporter)

Comment 5

18 years ago

*** This bug has been marked as a duplicate of 33684 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 6

18 years ago
verifying as dupe of 33684
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.