Firefox takes more and more memory, and 99% of the CPU on this page

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
major
RESOLVED WORKSFORME
12 years ago
9 years ago

People

(Reporter: Andrew, Unassigned)

Tracking

({hang, testcase})

Trunk
hang, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2009-07-07, URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060926 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060926 Minefield/3.0a1

When going to this site (http://www.lukeredpath.co.uk/2006/8/29/developing-a-rails-model-using-bdd-and-rspec-part-1) firefox becomes unresponsive and consumes more and more memory until it is killed.

Reproducible: Always

Steps to Reproduce:
1.Go to http://www.lukeredpath.co.uk/2006/8/29/developing-a-rails-model-using-bdd-and-rspec-part-1
2.
3.

Actual Results:  
Firefox becomes unresponsive and consumes all system resources.

Expected Results:  
Open the page.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060926 Minefield/3.0a1

Yeah, I see the same. It' a script on that page.
Keywords: hang

Comment 2

12 years ago
Ouch, this is pretty bad. No "slow running script" dialog, either. Maybe Martijn can come up with a minimized testcase.
Severity: critical → major
Status: UNCONFIRMED → NEW
Component: General → General
Ever confirmed: true
OS: Windows 2000 → All
Product: Firefox → Core
QA Contact: general → general
Hardware: PC → All
Summary: Firefox takes more and more memory, and 99% of the cpu. → Firefox takes more and more memory, and 99% of the CPU on this page
Version: unspecified → Trunk
Created attachment 240223 [details]
testcase

Well, when minimizing, I come to this.
It seems that the hang happens because a very large string is trying to be made.
I'm not sure if that is also the case with the url.

Updated

12 years ago
Assignee: nobody → general
Component: General → JavaScript Engine
QA Contact: general → general

Updated

12 years ago
Keywords: testcase

Comment 4

9 years ago
Is it much better for you using trunk/beta?

Not sure how bad this testcase was in FF2 or 3.0, but testcase isn't too bad in Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3
Whiteboard: closeme 2009-07-07

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.