Last Comment Bug 354356 - Default quotation punctuation is not language-sensitive
: Default quotation punctuation is not language-sensitive
Status: RESOLVED DUPLICATE of bug 16206
:
Product: Core
Classification: Components
Component: CSS Parsing and Computation (show other bugs)
: 1.8 Branch
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: David Baron :dbaron: ⌚️UTC-7 (busy September 14-25)
: Hixie (not reading bugmail)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-26 11:53 PDT by Benjamin Hawkes-Lewis
Modified: 2006-09-26 13:25 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Benjamin Hawkes-Lewis 2006-09-26 11:53:54 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20060925 BonEcho/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20060925 BonEcho/2.0

Firefox provides a default styling of the Q element. Like Lynx, Firefox alternates double with single quotation marks for nested quotations. But Firefox does not follow the HTML spec, which says: "User agents should render quotation marks in a language-sensitive manner (see the lang attribute)" [*]. Instead, Firefox uses the punctuation typical of US English every time.

[*] http://www.w3.org/TR/1999/REC-html401-19991224/struct/text.html#h-9.2.2.1 

Reproducible: Always

Steps to Reproduce:
1. Write an HTML page including: <p lang="fr">J'aime<q lang="fr">Firefox</q>!</p>
2. View it in Firefox.


Actual Results:  
J’aime “Firefox”!

Expected Results:  
J’aime « Firefox »!
Comment 1 Adam Guthrie 2006-09-26 13:25:23 PDT

*** This bug has been marked as a duplicate of 16206 ***

Note You need to log in before you can comment on or make changes to this bug.