New profiles without default tags (MigrateLabelsToTags broken)

RESOLVED FIXED

Status

MailNews Core
Backend
RESOLVED FIXED
12 years ago
10 years ago

People

(Reporter: Karsten Düsterloh, Assigned: Karsten Düsterloh)

Tracking

(4 keywords)

Trunk
fixed-seamonkey1.1b, fixed1.8.1, regression, verified1.8.1.3

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

12 years ago
Newly created profiles lack the five default tags (former labels), both in context menus and preferences.
(Assignee)

Comment 1

12 years ago
Created attachment 240210 [details] [diff] [review]
use correct prefBranch
Attachment #240210 - Flags: superreview?(bienvenu)
Attachment #240210 - Flags: review?(bienvenu)

Comment 2

12 years ago
Comment on attachment 240210 [details] [diff] [review]
use correct prefBranch 

Thx for the fix...

Just to be sure I understand, it looks like this broke when m_prefBranch was made to always point to mailnews.tags...maybe m_prefBranch should be renamed to something like m_tagsPrefSubBranch or something to be clearer. Also, getPrefService should be removed, as well as the calls to it, since it's not going to do the right thing.
Attachment #240210 - Flags: superreview?(bienvenu)
Attachment #240210 - Flags: superreview+
Attachment #240210 - Flags: review?(bienvenu)
Attachment #240210 - Flags: review+
(Assignee)

Comment 3

12 years ago
Created attachment 240346 [details] [diff] [review]
prefBranch correction + additional clean-up, v2

Additional clean-up as proposed in comment #2.

> Just to be sure I understand, it looks like this broke when m_prefBranch was
> made to always point to mailnews.tags...

Yes. Sorry about that. :(
Attachment #240346 - Flags: superreview?(bienvenu)
Attachment #240346 - Flags: review?(bienvenu)

Comment 4

12 years ago
Comment on attachment 240346 [details] [diff] [review]
prefBranch correction + additional clean-up, v2

looks good, thx.
Attachment #240346 - Flags: superreview?(bienvenu)
Attachment #240346 - Flags: superreview+
Attachment #240346 - Flags: review?(bienvenu)
Attachment #240346 - Flags: review+
(Assignee)

Comment 5

12 years ago
Comment on attachment 240346 [details] [diff] [review]
prefBranch correction + additional clean-up, v2

TB/SM only, low risk, regression fix.

Checked in on trunk.
Attachment #240346 - Flags: approval1.8.1?
Comment on attachment 240346 [details] [diff] [review]
prefBranch correction + additional clean-up, v2

a=beltzner on behalf of drivers
Attachment #240346 - Flags: approval1.8.1? → approval1.8.1+
(Assignee)

Comment 7

12 years ago
Landed on MOZILLA_1_8_BRANCH.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed-seamonkey1.1b, fixed1.8.1
Resolution: --- → FIXED
verified fixed 1.8.1.3 using Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1.3) Gecko/20070326 Thunderbird/2.0.0.0 Mnenhy/0.7.5.0 ID:2007032620 - new profile has default tags -> adding verified keyword
Keywords: verified1.8.1.3
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.