Closed Bug 354438 Opened 13 years ago Closed 12 years ago

Pressing "Enter" button no longer triggers Firefox 2.0 to load page.

Categories

(Firefox :: Address Bar, defect, major)

2.0 Branch
x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: kten50, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20060918 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20060918 Firefox/2.0

After I put an address into the Location Bar in Firefox 2.0 RC 1 and press the "Enter" button, nothing happens.  I started noticing this problem in Firefox 2.0 Beta 2 mostly after an address was autocompleted, but now I can't even get an address I type in or cut and paste in to work when I press the "Enter" button.  This results in me having to use the mouse to go up and press the arrow button next to the Location Bar, which I find inconvenient as I like to use keyboard shortcuts. 

Reproducible: Always

Steps to Reproduce:
1.type an address in to the Location Bar
2.press the "Enter" button
3.watch nothing happen




Expected Results:  
When I press the "Enter" button while in address is highlighted or a little "I" bar is in the Location Bar, Firefox should load the webpage listed.

I'm marking this "Major" because both Opera and Internet Explorer 7 along with Firefox 2.0 Beta 1 can load a web page when I press enter in their Location Bars, so I don't see why Firefox 2.0 RC 1 can't.
Flags: blocking-firefox2?
Version: unspecified → 2.0 Branch
*** Bug 354437 has been marked as a duplicate of this bug. ***
*** Bug 354436 has been marked as a duplicate of this bug. ***
*** Bug 354435 has been marked as a duplicate of this bug. ***
And does this happen in firefox's safemode?
- http://kb.mozillazine.org/Safe_mode

I suspect you are running TabMixPlus extension, which is known to cause a similar problem to the one you are experiencing.
Please don't set blocking flags on unconfirmed bugs. Stevee, can you get someone in #foxymonkies to check this out, and renom if it's confirmed.
Flags: blocking-firefox2?
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1) Gecko/20060918 Firefox/2.0 (rc1 official)
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1) Gecko/20060926 BonEcho/2.0 (nightly)

New profile in all cases.

Both Enter and Return in the URL bar WFM with any combination of just having the caret in the URL bar, having the whole URL bar highlighted or only having a section of the URL highlighted.

This tab mix plus dev build forum thread ( http://tmp.garyr.net/forum/viewtopic.php?p=11070#11070 ) contains many similar complaints of enter not working, which is entirely down to extensions.
WFM "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061002 BonEcho/2.0"
WFM:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/2007051502 Firefox/2.0.0.4

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a6pre) Gecko/2007060204 Minefield/3.0a6pre
Whiteboard: CLOSEME - 06/30 (WFM?)
mrking as WFM for last comments (and WFM), reopen if you can still see the problem
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
Whiteboard: CLOSEME - 06/30 (WFM?)
You need to log in before you can comment on or make changes to this bug.