Spell Checking on/off from javascript for designMode

RESOLVED WORKSFORME

Status

()

Core
DOM
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: ReleaseEngineer, Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20060918 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20060918 Firefox/2.0

I really understand the need for a spell checker, but why would that be on by default? and can only be turned on/off from options dialog? Not everybody writes documents and/or emails. For example, many people write code, scripts and so on. Seeing a java source code with tons of spell checking errors is not very good. There should be a meta tag or a javascript property for the contentDocument to be set on/off for spell checking. Or may be there is already something like that but undocumented!? 



Reproducible: Always
See http://developer.mozilla.org/en/docs/Controlling_spell_checking_in_HTML_forms
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

11 years ago
thanks for the info
(Reporter)

Comment 3

11 years ago
I just realized that the solution given on the link is not working for designMode. Are you aware of a way to turn it off when on designMode. That is what I am actually worried about.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Updated

11 years ago
Summary: Spell Checking on/off from javascript → Spell Checking on/off from javascript for designMode

Comment 4

11 years ago
This is /supposed/ to work. Can you provide a testcase that demonstrates the problem?
Assignee: nobody → general
Component: General → DOM
Product: Firefox → Core
QA Contact: general → ian
Version: unspecified → 1.8 Branch
I think he was talking about what he also mentioned in bug 333038, comment 28:
"
The solution to turn off spell checking when not needed for form elements has
been introduced with the fix in Bug 339127. And how do we turn it off when we
don't need it in designMode? 

perhaps something similar to execCommand("spellCheck",false,"false");??
"
In that way, web designers could control the spell checking ability in designMode documents.
I guess this might be a good idea, perhaps this should be raised at the whatwg mailing list?

Comment 6

11 years ago
See bug 333038 comment 29.  I hope all the conversation can be kept here, I don't want to try and keep both bugs in sync.
(In reply to comment #6)
> See bug 333038 comment 29.  I hope all the conversation can be kept here, I
> don't want to try and keep both bugs in sync.

Ok, then I'm marking this bug worksforme, because according to that comment it is already possible to disable spellchecking for designMode iframes.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → WORKSFORME

Comment 8

11 years ago
(In reply to comment #7)
> Ok, then I'm marking this bug worksforme, because according to that comment it
> is already possible to disable spellchecking for designMode iframes.

Well, you should check that it works before marking it as such.  I intended my "I don't have testcases lying around" comment there to be cautionary.
Created attachment 240555 [details]
testcase

Ok, here is an example of designMode with spellcheck="false" on the body element, this seems to work just fine.
(Reporter)

Comment 10

11 years ago
excellent!

thanks
You need to log in before you can comment on or make changes to this bug.