Junk mail loses status in junk folder (SMTP/POP)

RESOLVED DUPLICATE of bug 471682

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 471682
11 years ago
8 years ago

People

(Reporter: John Talbut, Unassigned)

Tracking

({qawanted})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.7) Gecko/20060830 Firefox/1.5.0.7 (Debian-1.5.dfsg+1.5.0.7-1)
Build Identifier: 1.5.0.5

Junk Mails that are marked and moved to the junk folder seem to
loose their junk-status in the junk folder without any special reason.


Reproducible: Always

Steps to Reproduce:
1.Click on junk mail flag on junk in inbox or junk mail is automatically falgged and in either case is sent to junk mail folder.
2.Junk mail appears in junk mail folder with junk flag set
3.Look in the junk mail folder later

Actual Results:  
The junk flags have disappeared


This is similar to bug 297766 except that it affects local folders using POP/SMTP and it is not resolved.

Comment 1

11 years ago
It'd definitely be worth testing to see if this happens in Thunderbird 2 alpha 1 (if this is possible).
Keywords: qawanted

Comment 2

11 years ago
I was testing bug 367255 and ran into this, in a test profile, moving from a folder-o-junk in a POP account to a junk folder under Local Folders.  The weird thing is, this is like my regular configuration, where practically all my incoming junk is on a POP account and is getting moved to a folder under Local Folders.

Both the first and second times I tried this, the junk was moved by (a) configuring Manual Mark *not* to move junk, (b) manually marking the junk, and (c) using Run Junk Mail Controls On Folder.  In both cases, the mail that was moved lost its junk status.

The third time I tried it, after manually marking the junk, I set the JMC setting such for Manual Mark = Move to Junk Folder (which is my normal configuration), then again selected Run Junk Mail Controls On Folder.  This time, the junk status stuck.

John Talbut, does that match your experience at all?

Comment 3

11 years ago
Comment 2 was tested with 1.5.0.9.  I just tried again using 2b1-0116, and this time the junk status was maintained even with "move on manual mark" turned off.
(Reporter)

Comment 4

11 years ago
Using 1.5.0.9 it does not seem to matter how the junk was moved to the junk folder, generally it will still be marked as junk at first.  Then, later when I look at the folder all the junk flags have gone.  It has just happened.

Comment 5

10 years ago
I encountered this problem on version 2.0.0.12 (20080213) (XP Pro). The junk status was removed when the junk folder was compacted. The workaround was to change the option "Compact folders when it will save over" to a much higher KB (i.e. 10000). The status change rarely happens and the junk folder is still compacted periodically.

Updated

9 years ago
Assignee: mscott → nobody

Comment 6

9 years ago
I encounter this problem too on TB3 beta. In my case 'losing the junk status' does not seems to relate to compacting the folders, because I have autocompacting turned off. 

(Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3pre) Gecko/20090116 Shredder/3.0b2pre)
(In reply to comment #0)
> Build Identifier: 1.5.0.5
> Reproducible: Always
>(snip) 
> Steps to Reproduce:
>(snip)
> 2.Junk mail appears in junk mail folder with junk flag set
> 3.Look in the junk mail folder later
> Actual Results:  
> The junk flags have disappeared

I can say nothing about what happend on you. But if it's assumed that internal "Rebuild Index" has been invoked, I think phenomenon can be explained.

(a) If crash/freeze etc. occurs during update of Junk folder, "Rebuild Index" of Junk folder can occur.
(b) If "Junk Purge" by retention policy etc. is enabled, and if mail.prompt_purge_threshhold=true and mail.purge.ask=false(user requested 'not ask anymore' in the past), "auto compaction" is silently kicked internally. This can produces contention with other operations(move by Junk/message filter, purge by retention policy, ...). And the contention can produce situation with which internal "Rebuild Index" will be invoked.

I think Bug 449768 is effective in such cases, although though Bug 449768 itself is enhancement rquest for manual "Rebuild Index".
> Bug 449768 Reindexing should save message metadata (junk-related, tags, etc.)

(In reply to comment #6)
> I encounter this problem too on TB3 beta.
> In my case 'losing the junk status' does not seems to relate to compacting the folders, because I have autocompacting turned off. 

Tb trunk has Bug 472446, Bug 471682, Bug 471130. Even after fix of Bug 449768, ".msf" can be corrupted. Valery Kondakoff, watch these bugs, please.

Comment 8

9 years ago
Please, take a look at this
(https://bugzilla.mozilla.org/show_bug.cgi?id=471503) bug. It seems it is
related to this problem someway...

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 471682
(In reply to comment #9)
> *** This bug has been marked as a duplicate of bug 471682 ***

To Kent James:
Original problem is report on Tb 1.5. Really DUP of Bug 471682? Bug 471682 really existed in Tb 1.5 era?
(I absolutely agree with you on that "internal rebuild index with Tb trunk" can be invoked by Bug 471682 or some bugs around it.)

Comment 11

9 years ago
The original change that likely caused bug 471682, at least as fixed by me, was in 2002. It's possible something broke it later, but this is not a recent problem.
(In reply to comment #11)
> The original change that likely caused bug 471682, at least as fixed by me, was
> in 2002. It's possible something broke it later, but this is not a recent
> problem.

I see. I guess;
(1) Problem in "open mail folder other than via UI" existed nearly since initial.
    But it didn't produce severe problem long time. 
(2) mail.db_timestamp_leeway was introduced.
    (to avoid frequent .msf recreation in multi-boot env or network file env)
(3) To resolve problem by (2), file size check(of mail folder file) was added.
(4) Bug 392704 changed rebuild index code(to not to loose tag/junk status etc.)
(5) Many problems have been exposed by change of Bug 471307...
You need to log in before you can comment on or make changes to this bug.