Investigation - Find Toolbar sometimes grabs all typed text

RESOLVED DUPLICATE of bug 1218351

Status

()

Toolkit
Find Toolbar
RESOLVED DUPLICATE of bug 1218351
12 years ago
2 years ago

People

(Reporter: 22markus, Unassigned)

Tracking

unspecified
x86
Windows 2000
Points:
1
Bug Flags:
firefox-backlog +
qe-verify ?

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

If there are some firefox windows open with heavy java script another started fresh window do not allow entry any strings in a current page into edit box. Find Toolbar entry catch all inputs. It is unposible to enter string into google web page because Firefox Find toolbar catch the string. I realized that turning of Java script help, but changing all the time this option to enter the string is weak.

Reproducible: Sometimes

Steps to Reproduce:
1. Open many Firefox windows with sites with java scripts
2. Open next one blanck and call google.com
3. Try enter search string. In my case this search string goes to Find toolbar on the bottom

Actual Results:  
It is stochastic, It is probabaly with some problems with Java scripts, as I said disabling java scripts helps

Updated

12 years ago
Blocks: 320465
Summary: Find Toolbar take all page entries → Find Toolbar sometimes grabs all typed text

Comment 1

11 years ago
I am still getting this effect using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

Other open bug reports that reference the problem: 340817, 354444, 354720.

The problem is that occasionally the "Quick Find" function becomes predatory and grabs focus every time a keystroke is entered in a form field. The Quick Find box can be closed (not visible) and it will still do this. This makes it impossible to fill in forms.

Interestingly, it will not catch the backspace key - i.e., you can delete characters in a form field, but not enter new ones (as they will go into the QuickFind box.

I cannot reproduce the problem, as it happens infrequently. Might be related to opening pdf files under Firefox?

It seems to be a long-standing problem. My solution is to exit Firefox and restart, but this is quite irritating.
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit

Comment 2

8 years ago
still see this in version 3 or trunk?

Updated

5 years ago
Blocks: 950073
Whiteboard: [defect] p=0

Updated

4 years ago
No longer blocks: 950073
Flags: firefox-backlog+
Whiteboard: [defect] p=0 → p=0

Updated

4 years ago
Summary: Find Toolbar sometimes grabs all typed text → Investigation - Find Toolbar sometimes grabs all typed text
Whiteboard: p=0 → p=1

Updated

4 years ago
Points: --- → 1
Flags: qe-verify?
Whiteboard: p=1
Closest to what you're experiencing is now being captured in bug 1218351 and has much more activity that'll lead to a solution.
If you feel this issue was closed in error, please feel free to re-open.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1218351
You need to log in before you can comment on or make changes to this bug.