fails to load all images/iframes from FTP when number of connections is limited

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
12 years ago
3 years ago

People

(Reporter: ehomyakov, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

When loading a page containing lots of images/iframes from single FTP server which limits number of connections per IP, only a few images are loaded. Others are not. Probably this is because Firefox tries to load them all at once and only a few FTP connection atempts succeed.

Reproducible: Always

Steps to Reproduce:
1. Visit a page containing links to 10-100 images on one FTP server which limits number of connections per IP to 1-4.
2. Wait until it loads. Get rid of all hundred of annoying message boxes (another bug is already logged about them).

Actual Results:  
You will see not all images have been loaded.

Expected Results:  
All images must be displayed.

Obviously, firefox must track all ftp connections attempts from all windows and tabs, and load all objects from single server one-by-one through one connection. Connection(s) to single FTP server must be shared between all windows and tabs.

There also can be a setting for each FTP server - how many connection it allows. More smart solution: try to establish second, third and more connections until one of them fail with "Too many connections per IP" error; when it happen, make it re-use already established connections. This will make it automatically detemine nubmer of allowed connections to this FTP from user's IP, even if it changed by FTP admin.
You're downloading webpages from an ftp? Got an example URL that shows this problem?
(Reporter)

Comment 2

12 years ago
Webpage is forum post on HTTP, which contain links to images that are on FTP. 
No response from reporter for an example URL --> INCOMPLETE.
Reporter, if you still see this problem then please reopen this bug. Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INCOMPLETE
Version: unspecified → 1.5.0.x Branch
(Reporter)

Comment 4

12 years ago
Yes it's still happening in latest update  (2.0.0.4)

My current workaround is to use HTTP proxy for FTP in firefox settings. When ftp images are downloaded through proxy, everything is ok - every image loaded.

Example url: http://ii.virtual.vps-host.net/ffftp.html

I cannot guarantee that images will stay there for long, this is not my ftp server.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
(Reporter)

Comment 5

11 years ago
I think I have figured out the problem. all below is about Firefox 2.0.0.11

Firefox opens new FTP connection socket for each image. After image is downloaded, the connection is closed and hang in TIME_WAIT state for a few seconds (due to TCP specs). Use netstat -n to see this. So this is what happens:

1. Firefox download page with 10 images which are on FTP. Example: http://ii.virtual.vps-host.net/ffftp.html
2. FTP allows only 2 connection for IP.
3. Firefox downloads one image, and this connection switches to TIME_WAIT
4. Firefox downloads second image, and this connection switches to TIME_WAIT
5. Firefox tries to open connection for third image, but FTP already have 2 connections from it (they are in TIME_WAIT), so it rejects connection. Firefox fails to load third image, and displays annoying popup message box with FTP error.
6. Firefox fails to load all or some of other images, depending on your internet connection speed, displaying annoying message box many times for each failed image.

What it should do is to re-use FTP session if there are more things to download from this FTP.
(Reporter)

Updated

11 years ago
OS: Windows XP → All
Version: 1.5.0.x Branch → 2.0 Branch
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b3pre) Gecko/2007121805 Minefield/3.0b3pre ID:2007121805

OK, I see this problem on a trunk build too. Eugene, it would be great if you could test with a trunk build and verify the problem still exists.
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
Component: General → Networking
Product: Firefox → Core
QA Contact: general → networking
Version: 2.0 Branch → Trunk
(Reporter)

Comment 7

11 years ago
Checked firefox-3.0b3pre 21-Dec-2007 5:31 (+6) — bug is still there.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.