All users were logged out of Bugzilla on October 13th, 2018

Memory not freed with Java (not in Firefox before 1.5 and in IE)

RESOLVED FIXED

Status

()

--
critical
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: dieter.menne, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; de; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; de; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

Try the page shown in URL, and press the yellow NEXT button several times. After 4 to 5 runs, Firefox stalls because of memory overflow. The error does not occur in IE, and most likely not in earlier versions of Firefox before 1.5 (not fully sure, because Java also changed). It can be reproduced with Firefox 2.0 RC 1.

The Java program uses JavaView by Konrad Polthier, who has confirmed this to be a possible bug in Firefox. Java Sources are available on http://www.menne-biomed.de/swallow/JSwallow3d.java.



Reproducible: Always
(Reporter)

Comment 1

12 years ago
(Note added by original poster: here is the console output after 5 runs)

*** Info of JavaView *********
	JavaView v3.95, see www.javaview.de
	Topic of this version = release version

Assigned: codeBase = http://www.menne-biomed.de/swallow/
Assigned: codeBase = http://www.menne-biomed.de/swallow/
Assigned: codeBase = http://www.menne-biomed.de/swallow/
Assigned: codeBase = http://www.menne-biomed.de/swallow/
Assigned: codeBase = http://www.menne-biomed.de/swallow/
Error: Out of memory occurred! Try using command line parameter
  java -Xmx256m or -Xmx512m or higher
to increase the maximal memory available to the virtual machine.
	at jv.object.PsDebug.outOfMemory(PsDebug.java)
(Reporter)

Comment 2

12 years ago
Problem seems to be solved in Firefox 2
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.