If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

I'm linked to google.com even if I use the italian version of Firefox

RESOLVED WORKSFORME

Status

()

Firefox
Search
--
major
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: Mario Serafini, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.1) Gecko/20060918 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.1) Gecko/20060918 Firefox/2.0

I'm using the italian version of Firefox
When I use the embedded search engine Google, I'm redirect to Google.com web site. So that all the results of my search are loaded from english web pages. 
For example if I search for "cane" (an italian word that means dog) the results are all the english pages that deals with the canes. No one of them deals with dogs (in italian, obviously).
I've tried to install ffox on another PC on which ffox was never installed before but the same problem was still there.

I've just solved the problem changing the google.xml file. I've changed, in that file, all the items google.com to google.it and now everythig is ok.

I hope this warning is useful to you.

Bye and thanks a lot for your wonderful work.

Mario Serafini


Reproducible: Always

Steps to Reproduce:
1. Download the Firefox 2.0 or candidate realease (italian version) and install it.
2. use a bivalent search key (such as cane)
3. look at the results
Seems like Google isn't sniffing an Italian accept-lang...
Is this still a problem?

Comment 3

11 years ago
The actual search plugin (like the 1.5.X one) points to google.com, and Google itself redirect the request to google.it.

It seems a per user problem (like bad language settings in the preferences of Google http://www.google.com/preferences ).

I'm closing the bug with "works for me".
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.