CSS background-color bugs on selectedIndex option at select element

RESOLVED DUPLICATE of bug 79107

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 79107
11 years ago
11 years ago

People

(Reporter: Fernando Wendt, Unassigned)

Tracking

1.8 Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

The Firefox CSS engine does not work properly when applying the "background-color" propertie on the SELECT element at selectedIndex position.

The background-color works fine when listing all the OPTION child nodes from the object. It only does not mark the SELECTED one with the apropriate defined/dynamicly setted propertie value. By default, it is always white background color.

Reproducible: Always

Steps to Reproduce:
1.At your web page, add a SELECT element, with some few OPTIONS neasted nodes.
2.Set the style background-color attribute to different values as you wish.
3.Change the selected option and see: the background color always will be withe.

Actual Results:  
The SELECTED option is background filled with the withe color, always.

Expected Results:  
It should take the (optional) CSS attribute value, from the stylesheet attribute tag or from the style JavaScript object.
Component: General → Layout: Form Controls
Product: Firefox → Core
QA Contact: general → layout.form-controls
Version: unspecified → 1.8 Branch

Comment 1

11 years ago
> The background-color works fine when listing all the OPTION child nodes from
> the object. It only does not mark the SELECTED one with the apropriate
> defined/dynamicly setted propertie value.

Well, if you dynamically set the background-color of the select to the background-color of the selected option like in this page

http://www.gtalbot.org/DHTMLSection/AdvancedCSSButtons.html

then it should work for you.

> Expected Results:  
> It should take the (optional) CSS attribute value, from the stylesheet
> attribute tag or from the style JavaScript object.

Please, Fernando, always look/do a bit of searching for duplicates. After a bit of search, your bugfile was the same as bug 180728, bug 90090, bug 56451.

I'm resolving this bug as a duplicate of bug 79107.

*** This bug has been marked as a duplicate of 79107 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

11 years ago
OK, but i do have made a search before bug reporting. Sorry if my keyworkds haven´t mached with the previous ones, but i do try to set the practical focus on my reports.

My fault. Best regards.
You need to log in before you can comment on or make changes to this bug.