bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

New Mail Sound Browse doesn't remember last used path

RESOLVED FIXED in Thunderbird 3.0b2

Status

Thunderbird
General
--
minor
RESOLVED FIXED
12 years ago
10 years ago

People

(Reporter: Ilya Konstantinov, Assigned: prasad)

Tracking

Thunderbird 3.0b2
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
When pressing Preferences | Custom .wav sound -> [Browse], the file browsing dialog (Gtk2, at least) doesn't start off in the same directory as the current sound; instead, it starts off in the working directory.

This is inconvenient, e.g. when you're trying out different sounds.

Updated

12 years ago
Severity: normal → minor
Summary: New Mail Sound Browse doesn't start in the current sound directory → New Mail Sound Browse doesn't remember last used path
Version: 1.5 → 2.0

Updated

11 years ago
Duplicate of this bug: 377146

Comment 2

11 years ago
With Thunderbird 2.0.0.6 in Ubuntu 7.10 b1, the bug still there.

Updated

10 years ago
Assignee: mscott → nobody
(Assignee)

Comment 3

10 years ago
Created attachment 360750 [details] [diff] [review]
Fix

This patch fixed the bug in Spicebird and works good for Thunderbird too.
Assignee: nobody → prasad
Status: NEW → ASSIGNED
Attachment #360750 - Flags: review?(bugzilla)
Attachment #360750 - Flags: review?(bugzilla) → review?(mkmelin+mozilla)
Comment on attachment 360750 [details] [diff] [review]
Fix

I'm sure it works, however my Linux environment is down for a day or two, so I can't test this. Hopefully Magnus can do the review.

Updated

10 years ago
Attachment #360750 - Flags: review?(mkmelin+mozilla) → review+

Comment 5

10 years ago
Comment on attachment 360750 [details] [diff] [review]
Fix

Looks good Prasad - thanks for the patch! r=mkmelin
(Assignee)

Comment 6

10 years ago
changeset:   1873:4f349459d112
tag:         tip
user:        Prasad Sunkari <prasad@medhas.org>
date:        Fri Feb 06 23:16:40 2009 +0530
summary:     Bug 354938 -  New Mail Sound Browse doesn't remember last used path, r=mkmelin
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

10 years ago
Target Milestone: --- → Thunderbird 3.0b2
You need to log in before you can comment on or make changes to this bug.