Administrative Subscription Maintenance Error.

RESOLVED WORKSFORME

Status

mozilla.org
Talkback Server & Webtool
P3
normal
RESOLVED WORKSFORME
18 years ago
13 years ago

People

(Reporter: Shiva Thirumazhusai, Assigned: Shiva Thirumazhusai)

Tracking

Details

(Assignee)

Description

18 years ago
Not able to delete Administrative Subscription Reports. But able
to change attributes and save the report.



  Problem: 
  An error has occurred while processing the expression:

  result=EmailHelper.DeleteEmailReport(#reportID#, 0, 1)

 The error occurred on (or near) line 5 of the template file 
C:\Talkback\website\admin\deleteemailreport.cfm.

  1: <cfif IsDefined("URL.reportID")>
  2:         <cfset reportID = #URL.reportID#>
  3: 
  4:         <cfobject class=AdminHelper.EmailHelper.1 name="EmailHelper" 
action="Create">
  5:         <cfset result=EmailHelper.DeleteEmailReport(#reportID#, 0, 1)>
  6: </cfif>

Comment 1

18 years ago
*** Bug 35498 has been marked as a duplicate of this bug. ***

Comment 2

18 years ago
*** Bug 35496 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 3

18 years ago
Digging deep down the problem. It is seems something to do with ODBC and
invalidation of time. I don't understand the error " Encountered ODBC error -1: 
S1011, 0, [Oracle][ODBC]Operation invalid at this time."
Rest of the ODBC functions are working. I don't know what is so different in
this operation than the other operations. Getting manifest also uses query
helper. 

I check the versions for adminhelper.dll everything is pointing to Version 2.2.
Is there any particular table which holds the report information like id and so 
on




04/12 09:54:38 (00FC): 001e89c8  0080230843  New CQueryHelper
04/12 09:54:39 (00FC): 001e89c8  0080231375  CQueryHelper::~CQueryHelper
04/12 09:55:53 (00D0): 001e89c8  0080305531  New CQueryHelper
04/12 09:55:53 (00D0): 001e89c8  0080305703  CQueryHelper::~CQueryHelper
04/12 09:56:14 (00D7): Encountered ODBC error -1: S1011, 0, [Oracle][ODBC]Operat
ion invalid at this time.
Status: NEW → ASSIGNED
This bug has not been touched for more than nine months. In most cases, that 
means it has "slipped through the net". Please could the owner take a moment to 
add a comment to the bug with current status, and/or close it.

Thank you :-)

Gerv

Comment 5

18 years ago
closing.  we should track somewhere else
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Updated

13 years ago
Component: Talkback → Talkback
Product: Core → mozilla.org
Version: Trunk → other
You need to log in before you can comment on or make changes to this bug.