Multiple document.loadOverlay calls in succession result in exceptions (NS_ERROR_FAILURE from nsIDOMXULDocument.loadOverlay) thrown and overlays not getting loaded

RESOLVED DUPLICATE of bug 330458

Status

()

Core
XUL
RESOLVED DUPLICATE of bug 330458
11 years ago
9 years ago

People

(Reporter: stevee, Unassigned)

Tracking

({assertion, testcase})

Trunk
x86
Windows XP
assertion, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
Filed at request of asqueella via IRC

1. New profile, start firefox
2. Tools > Options
3. Click on 'Main' tab to give it focus
4. Hold down right arrow key. Observe the tabs in the pref window are cycled through at speed.
5. Release the arrow key. Now click on all the tabs one by one

Expected:
Relevant preferences in all tabs are displayed

Actual:
Some pref tabs will appear blank

This occurs on:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1) Gecko/20061001 BonEcho/2.0 ID:2006100103
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/2006092304

Additionally, the error console throws many exceptions (this from the trunk):
Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIDOMXULDocument.loadOverlay]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://global/content/bindings/preferences.xml :: showPane :: line 647"  data: no]

Updated

11 years ago
Component: Preferences → XP Toolkit/Widgets: XUL
OS: Windows 2000 → Windows XP
Product: Firefox → Core
QA Contact: preferences → xptoolkit.xul
Version: 2.0 Branch → Trunk

Comment 1

11 years ago
testcase at http://mozilla.doslash.org/stuff/overlays-test/test9.xul , just two loadOverlay() calls in succession. Loading the second overlay after a timeout fixes the problem: http://mozilla.doslash.org/stuff/overlays-test/test9.1.xul

The testcase doesn't throw exceptions though, but I guess it depends on timing.
Keywords: testcase
Summary: After cycling through pref window's tabs by holding down left/right arrow key, exceptions thrown and some pref tabs appear empty → Multiple document.loadOverlay calls in succession result in exceptions (NS_ERROR_FAILURE from nsIDOMXULDocument.loadOverlay) thrown and overlays not getting loaded

Comment 2

11 years ago
Also asserts for me:
###!!! ASSERTION: forward references have already been resolved: 'Error', file c:/mozilla/content/xul/document/src/nsXULDocument.cpp, line 1049
and leaks on shutdown.
Keywords: assertion

Comment 3

11 years ago
Turned out this was already filed.

*** This bug has been marked as a duplicate of 330458 ***
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE

Updated

9 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: xptoolkit.xul → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.