If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Imported saved passwords are disappearing after exiting Firefox.

RESOLVED WORKSFORME

Status

()

Toolkit
Password Manager
--
major
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: Claud, Unassigned)

Tracking

1.8.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 06/28)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

After importing passwords from Netscape 7.2, they are present, accurate and active for the present loaded session. After exiting and calling Firefox again, all the imported passwords have vanished and any new passwords added in the prior session are still present. If I reimport passwords again, they are present for the current session but disappear again after leaving the session. All my options in 'Tools' have been set to NOT clear passwords and this still happens. However, imported bookmarks are unaffected and are always up-to-date from session to session. This is intollerable. I am returning to Netscape until this is resolved by either a fix or someone telling me what I may be doing wrong.

Reproducible: Always

Steps to Reproduce:
1.Load Firefox.
2.Import passwords from Netscape.
3.Use the passwords for the current session.
4.Exit Firefox.
5.Reload Firefox.
6.Check for stored passwords in Tools/Options.
7.The imported passwords are gone.

Actual Results:  
If I do not reimport passwords from Netscape, I have to manually enter login data for every site that I wish to log into that was on file under Netscape.

Expected Results:  
Once the passwords were imported and verified, they should have stayed from session to session and allowed to grow with new additions as activity progressed. There should be no need to continually reimport for every session with the knowledge that what I added in the last session was not there.

Default theme. Standard PC running Win XP Pro. Has been an extremely stable platform.

Comment 1

11 years ago
I was going to file a bug of my own, but this may be related.  Calling addUser for an existing signon updates it for the session, but it's gone after a restart.  Sample code:

var m = Components.classes['@mozilla.org/passwordmanager;1'];
m = m.getService(Components.interfaces.nsIPasswordManager);
m.QueryInterface(Components.interfaces.nsIPasswordManager);
/* NEW users will persist */
m.addUser('http://www.example.com/', 'username', 'password');
/* CHANGES to existing users will not */
m.addUser('http://www.example.com/', 'username', 'possward'); 


After executing this code, there will be an entry with 'possward' but after a restart it will have returned to 'password.'  Tested in 1.5 and 2.0
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 07/14
Version: unspecified → 1.5.0.x Branch
(Reporter)

Comment 3

10 years ago
This problem has been fixed since at least January 2007. Didn't know that you still had it open. Now, maybe, you can fix the 374669 bug???
Reporter, please respond if you are still experiencing this bug.

I have tried to reproduce it, and based on previous comments, this bug is no longer an issue.

I did the following to try to reproduce the bug:
1. Download and install Netscape 7.2
2. Login to gmail, save password
3. Login to facebook, save password
4. Go to password manager to confirm passwords saved (confirmed)
5. Close Netscape and install Firefox 1.5.0.12
6. Run Firefox and tell it to import passwords from Netscape
7. Check password manager to confirm passwords saved (confirmed)
8. Visit gmail, username and password field auto-filled in properly
9. Visit facebook, username and password field auto-filled in properly
10. Restart firefox
11. Visit gmail, username and password field auto-filled in properly
12. Visit facebook, username and password field auto-filled in properly

If you are still experiencing issues, I recommend you try using Firefox 1.5.0.12.  Unless you comment on this bug within a week, this bug will be resolved as WORKSFORME.

Whiteboard: CLOSEME 07/14 → CLOSEME 06/28
No response from the reporter.  This bug is being resolved as WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.