mac OS X vertical scrollbar ignores mouse input at top of page

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: joe, Unassigned)

Tracking

2.0 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20060918 Firefox/2.0
Build Identifier: http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/2.0rc1/mac/en-US/Firefox%202.0%20RC%201.dmg

using firefox RC1
when using firefox in normal web browsing
at the beginning of the page, the vertical scrollbar 100% vertical, if you click on it and drag it down, it ignores mouse input. if you use the keyboard to move the page down at all, the vertical scrollbar starts working.
if you take it back to the top it stops working again.

Reproducible: Always

Steps to Reproduce:
1. open any web page taller than 1 screen (with active vertical scrollbar)
2. click on the blue "handle" in the vertical scrollbar at the top of the page
3. drag it down as far as you want
Actual Results:  
the handle (and web page) will not move at all.


Expected Results:  
the displayed area of the web page will scroll down (the contents will move up)

this was not on my PC, it was on a friend's mac, so i don't have full OS version details. 

i searched for mac scrollbar mouse and looked at all the bugs and didn't see this already listed. however it seems like a fairly huge bug so i wonder if it's already been reported somewhere.
(Reporter)

Comment 1

12 years ago
one additional comment: this is on a brand new mac powerbook provided by work, without any other known issues or conflicting software

Comment 2

12 years ago
Created attachment 247504 [details]
Image showing location of scrollbar problem on OSX

Comment 3

12 years ago
Clicking on empty scroll area below thumb does successfully scroll, as does using the arrows.
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> Clicking on empty scroll area below thumb does successfully scroll, as does
> using the arrows.
> 

this was a fresh install on a work laptop, but the laptop has since been replaced and the bug is not reproducible on the new laptop. if it happens again i'll update with specific information on how to reproduce
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 07/14
Version: unspecified → 2.0 Branch

Comment 6

11 years ago
WORKSFORME in Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a7pre)
Gecko/2007072500 Minefield/3.0a7pre

There have been no more recent comments on this bug 

-> WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Updated

11 years ago
Whiteboard: CLOSEME 07/14
You need to log in before you can comment on or make changes to this bug.