Filter does not recognize empty messages with date 1970

RESOLVED DUPLICATE of bug 355165

Status

Thunderbird
General
--
minor
RESOLVED DUPLICATE of bug 355165
11 years ago
11 years ago

People

(Reporter: Joerg Starkmuth, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

I frequently receive E-mails (probably corrupted spam or whatever) that have a size of 0 bytes and the date 01/01/1970. They normally appear in couples, i.e. two identical messages of this type at the same time. The junk filter recognizes them as I want it to and moves them to the Junk folder. But trying to delete them right away with the normal message filter does not work. I set the filter to look for file dates before 1970 and/or file sizes of 0 bytes, but none of these two settings detect these messages.

Reproducible: Always

Steps to Reproduce:
1. Receive 0 bytes message(s) with date 01/01/1970.
2. Set up filter to look for file dates before 1970 and/or file sizes of 0 bytes and to delete those messages.
3. Apply filter to the folder containing the message.

Actual Results:  
Message should be deleted.

Expected Results:  
Message are not deleted.
(Reporter)

Comment 1

11 years ago
Oops, sorry: "file dates before 1970" should have read "file dates before 1971".

*** This bug has been marked as a duplicate of 355165 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

11 years ago
Sorry for posting this bug twice, my fault ...
You need to log in before you can comment on or make changes to this bug.