Last Comment Bug 355179 - Vista - Sets the current process as dpi aware
: Vista - Sets the current process as dpi aware
Status: RESOLVED FIXED
: fixed1.8.1.1
Product: Core
Classification: Components
Component: Widget (show other bugs)
: Trunk
: x86 Windows Vista
: -- normal (vote)
: ---
Assigned To: Doug Turner (:dougt)
:
Mentors:
Depends on:
Blocks: 352420
  Show dependency treegraph
 
Reported: 2006-10-02 17:27 PDT by Doug Turner (:dougt)
Modified: 2006-11-20 20:10 PST (History)
3 users (show)
dveditz: blocking1.8.1.1+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch v.1 (1.16 KB, patch)
2006-10-02 20:51 PDT, Doug Turner (:dougt)
no flags Details | Diff | Review
patch v.2 (1.17 KB, patch)
2006-10-02 21:32 PDT, Doug Turner (:dougt)
dougt: review+
Details | Diff | Review

Description Doug Turner (:dougt) 2006-10-02 17:27:25 PDT
On vista, there is the ability to change the dpi used.  If we do not mark the application as DPI aware, when going into this mode Firefox text looks blurry.

Vista provides an API to mark the application as DPI aware.  We should use it:

http://msdn.microsoft.com/library/default.asp?url=/library/en-us/winui/winui/windowsuserinterface/windowing/windows/windowreference/windowfunctions/setprocessdpiaware.asp
Comment 1 Doug Turner (:dougt) 2006-10-02 20:51:57 PDT
Created attachment 241012 [details] [diff] [review]
patch v.1
Comment 2 Doug Turner (:dougt) 2006-10-02 21:23:11 PDT
Comment on attachment 241012 [details] [diff] [review]
patch v.1

this patch isn't something to checkin.
Comment 3 Doug Turner (:dougt) 2006-10-02 21:32:50 PDT
Created attachment 241017 [details] [diff] [review]
patch v.2

fixed cast.  wondering if we can avoid LoadLibrary.  it is fine to do it this way, but I remember there exists way to avoid the LoadLibrary when the library is implicitly linked.
Comment 4 Doug Turner (:dougt) 2006-10-09 13:26:13 PDT
Comment on attachment 241017 [details] [diff] [review]
patch v.2

r=vlad.
Comment 5 Doug Turner (:dougt) 2006-11-08 12:34:38 PST
on the trunk for a while.  safe fix.
Comment 6 Doug Turner (:dougt) 2006-11-17 11:42:42 PST
Checking in widget/src/windows/nsToolkit.cpp;
/cvsroot/mozilla/widget/src/windows/nsToolkit.cpp,v  <--  nsToolkit.cpp
new revision: 3.69; previous revision: 3.68
done

i thought i checked this in a while ago, turns out I didn't.  It has been in my tree for a while.
Comment 7 Doug Turner (:dougt) 2006-11-20 20:10:38 PST
Checking in nsToolkit.cpp;
/cvsroot/mozilla/widget/src/windows/nsToolkit.cpp,v  <--  nsToolkit.cpp
new revision: 3.48.4.8; previous revision: 3.48.4.7
done

Note You need to log in before you can comment on or make changes to this bug.