Crash loading testcase from bug 197956

VERIFIED FIXED

Status

()

Core
XSLT
--
critical
VERIFIED FIXED
11 years ago
11 years ago

People

(Reporter: bz, Unassigned)

Tracking

(Blocks: 1 bug, {crash, regression})

Trunk
x86
Linux
crash, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

This is a regression from bug 221335.  Load jar:https://bugzilla.mozilla.org/attachment.cgi?id=117559!/Nested_Chapter_Test.xml and watch Gecko crash.

The problem is:

(gdb) frame 1
#1  0xb6741391 in txMozillaXMLOutput::startElementInternal (this=0x87c7860, aPrefix=0x0, 
    aLocalName=0x80b7658, aNsID=3, aElemType=3)
    at ../../../../../mozilla/content/xslt/src/xslt/txMozillaXMLOutput.cpp:546
546         rv = mNodeInfoManager->GetNodeInfo(aLocalName, aPrefix, aNsID,
(gdb) p mNodeInfoManager
$1 = {mRawPtr = 0x0}
Created attachment 241078 [details] [diff] [review]
v1
Attachment #241078 - Flags: superreview?(bugmail)
Attachment #241078 - Flags: review?(bugmail)
Attachment #241078 - Flags: superreview?(bugmail)
Attachment #241078 - Flags: superreview+
Attachment #241078 - Flags: review?(bugmail)
Attachment #241078 - Flags: review+
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Keywords: crash, regression
Blocks: 355340
*** Bug 355340 has been marked as a duplicate of this bug. ***
No longer blocks: 355340
Verified FIXED; when I load jar:https://bugzilla.mozilla.org/attachment.cgi?id=117559!/Nested_Chapter_Test.xml I see the XML document in its tree structure, just fine.

Build: 2006-10-05-08 of Windows XP SeaMonkey trunk.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.