Crash when calling reloadChrome() [@ nsMenuX::OnCreate]

RESOLVED DUPLICATE of bug 326882

Status

--
critical
RESOLVED DUPLICATE of bug 326882
12 years ago
8 years ago

People

(Reporter: thomas.zoechling, Assigned: jaas)

Tracking

({crash})

1.8 Branch
PowerPC
Mac OS X
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a1) Gecko/20060914 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a1) Gecko/20060914 Minefield/3.0a1

reloadChrome seems to work as long I don't click the MenuBar in OSX.
But as soon as I try to interact with the Menu the Browser crashes.
The problem seems to be OSX specific (see stack trace)

Reproducible: Always

Steps to Reproduce:
1. call Components.classes["@mozilla.org/chrome/chrome-registry;1"].getService(Components.interfaces.nsIXULChromeRegistry).reloadChrome();
2. Click a menu item (excpet the Apple or the App Item)
3. browser goes down

Actual Results:  
Crash

Expected Results:  
Happiness!

Version: 3.0a1 (3.0a1)

PID:    2885
Thread: 0

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x00000000

Thread 0 Crashed:
0   libwidget_mac.dylib         0x011c4b62 nsMenuX::OnCreate() + 740
1   libwidget_mac.dylib         0x011c50cc nsMenuX::MenuSelected(nsMenuEvent const&) + 138
2   libwidget_mac.dylib         0x011c3284 MyMenuEventHandler(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*) + 532
3   com.apple.HIToolbox         0x92dcc7eb DispatchEventToHandlers(EventTargetRec*, OpaqueEventRef*, HandlerCallRec*) + 1093
4   com.apple.HIToolbox         0x92dcbe90 SendEventToEventTargetInternal(OpaqueEventRef*, OpaqueEventTargetRef*, HandlerCallRec*) + 304
5   com.apple.HIToolbox         0x92dcbd55 SendEventToEventTargetWithOptions + 55
6   com.apple.HIToolbox         0x92e6f373 SendMenuOpening(MenuSelectData*, MenuData*, double, unsigned long, __CFDictionary*, unsigned char, unsigned char*) + 471
7   com.apple.HIToolbox         0x92e6ee93 DrawTheMenu(MenuSelectData*, __CFArray**, unsigned char*) + 209
8   com.apple.HIToolbox         0x92e6ec78 MenuChanged(MenuSelectData*) + 218
9   com.apple.HIToolbox         0x92e6df7e TrackMenuCommon(MenuSelectData&, unsigned char*) + 700
10  com.apple.HIToolbox         0x92e6bf10 MenuSelectCore(MenuData*, Point, double, unsigned long, OpaqueMenuRef**, unsigned short*) + 224
11  com.apple.HIToolbox         0x92e6baf4 MenuSelect + 100
12  libwidget_mac.dylib         0x011bc6cd nsMacMessagePump::DoMouseDown(EventRecord&) + 215
13  libwidget_mac.dylib         0x011bcc42 nsMacMessagePump::DispatchEvent(EventRecord*) + 66
14  libwidget_mac.dylib         0x011bcca4 nsMacMessagePump::WNETransitionEventHandler(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*) + 40
15  com.apple.HIToolbox         0x92dcc7eb DispatchEventToHandlers(EventTargetRec*, OpaqueEventRef*, HandlerCallRec*) + 1093
16  com.apple.HIToolbox         0x92dcbe90 SendEventToEventTargetInternal(OpaqueEventRef*, OpaqueEventTargetRef*, HandlerCallRec*) + 304
17  com.apple.HIToolbox         0x92dd30f0 SendEventToEventTarget + 56
18  com.apple.HIToolbox         0x92dd3b12 ToolboxEventDispatcherHandler(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*) + 2586
19  com.apple.HIToolbox         0x92dccba2 DispatchEventToHandlers(EventTargetRec*, OpaqueEventRef*, HandlerCallRec*) + 2044
20  com.apple.HIToolbox         0x92dcbe90 SendEventToEventTargetInternal(OpaqueEventRef*, OpaqueEventTargetRef*, HandlerCallRec*) + 304
21  com.apple.HIToolbox         0x92dd30f0 SendEventToEventTarget + 56
22  libwidget_mac.dylib         0x011b0740 nsAppShell::ProcessNextNativeEvent(int) + 134
23  libwidget_mac.dylib         0x011d76e6 nsBaseAppShell::DoProcessNextNativeEvent(int) + 34
24  libwidget_mac.dylib         0x011d789c nsBaseAppShell::OnProcessNextEvent(nsIThreadInternal*, int, unsigned) + 168
25  libxpcom_core.dylib         0x002f4607 nsThread::ProcessNextEvent(int, int*) + 107
26  libxpcom_core.dylib         0x002bc379 NS_ProcessNextEvent_P(nsIThread*, int) + 53
27  libwidget_mac.dylib         0x011d772b nsBaseAppShell::Run() + 57
28  libtoolkitcomps.dylib       0x012dadd3 nsAppStartup::Run() + 45
29  XUL                         0x00053f6a XRE_main + 11140
30  org.mozilla.firefox         0x00002ef0 main + 40
31  org.mozilla.firefox         0x00002842 _start + 228 (crt.c:272)
32  org.mozilla.firefox         0x0000275d start + 41

Updated

12 years ago
Assignee: nobody → joshmoz
Severity: minor → critical
Component: OS Integration → Widget: Mac
Keywords: crash
Product: Firefox → Core
QA Contact: os.integration → mac
Summary: Crash when calling reloadChrome() → Crash when calling reloadChrome() [@ nsMenuX::OnCreate]
Version: unspecified → 1.8 Branch

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 326882 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

9 years ago
Component: Widget: Mac → Widget: Mac
Product: Core → Core Graveyard
Crash Signature: [@ nsMenuX::OnCreate]
You need to log in before you can comment on or make changes to this bug.