Title tags in <pre> area are not printed.

RESOLVED INVALID

Status

()

RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

If a <title>foo</title> tag is present inside a <pre> zone, it will not be printed.

Reproducible: Always

Steps to Reproduce:
1. Write a Perl script:
#!/usr/bin/perl
print "Content-type: text/html\n\n";
print "<pre>
title: one
<title>two</title>
no title: three</pre>";
exit;

2. Expected result: 
title: one
<title>two</title>
no title: three

3. Actual result:
title: one
[blank line]
no title: three

Comment 1

12 years ago
Using the title element outside of the head is invalid HTML.  There is a blank line because that title is moved to the head.  If you wish to display HTML code in a pre element then you need to use entities.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.