source files in stacktraces should not be lower-cased

RESOLVED WONTFIX

Status

mozilla.org
Talkback Server & Webtool
RESOLVED WONTFIX
12 years ago
7 years ago

People

(Reporter: Andrew Schultz, Assigned: jay)

Tracking

Details

(Reporter)

Description

12 years ago
talkback stacks include frames with references to source files like 
[mozilla\docshell\shistory\src\nsshistory.cpp, line 798]
with the source files lower-cased (it should be nsSHistory.cpp).  This should not happen and it prevents the bonsai links from working (along with bug 331397).

Comment 1

11 years ago
I ran into this after fixing bug 331397. As far as I can tell, the source file name is in lowercase when we pull it out of the database. I don't see any place where we lowercase it ourselves... I don't know how the database works at all; maybe Jay can pipe in on that.

Updated

11 years ago
Duplicate of this bug: 383865

Comment 3

11 years ago
I mentioned this to Ted (luser) on IRC, when he was working on Breakpad stuff related to this (bug 383083). He said it probably has something to do with how VC8 makes its symbol files. Anyway, this will be fixed in Breakpad (as soon as I write the code to provide UI for it).
We have not used Talkback in years and it is not longer maintained. Closing bugs.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.