.dmg file format type does not show in save dialog

RESOLVED WORKSFORME

Status

()

Firefox
File Handling
RESOLVED WORKSFORME
12 years ago
a year ago

People

(Reporter: marcia, Unassigned)

Tracking

2.0 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

Filing as general, but this is probably a server side issue so most likely needs t move.

Seen using Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1) Gecko/20061003 Firefox/2.0.

STR:

1. Set your download preferences in Preferences to "Always ask me where to save files"
2. Download a Mac disk image from mozilla.com domain (http://www.mozilla.com/products/download.html?product=firefox-1.5.0.7&os=osx&lang=en-US).
3. Observe attached screenshot, where the format is left blank.

If I download a .dmg from another domain, it shows properly as a binary file.

I see this on Win XP too, if I download a Mac file from the mozilla.com products page it does not show the format type, but does for Windows and Linux.
(Reporter)

Comment 1

12 years ago
Created attachment 241217 [details]
Screenshot of problem using RC2 candidate build
(Reporter)

Comment 2

12 years ago
Created attachment 241218 [details]
Screenshot using same build and showing .exe file successfully
Created attachment 241220 [details]
Download Windows dmg on Windows 2000 SP4

WFM on Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1) Gecko/20061003 Firefox/2.0, seems to be a Mac Problem ?
Created attachment 241223 [details]
on the 2nd step the Download Type is missing on Windows 2000 SP4
*** Bug 355437 has been marked as a duplicate of this bug. ***
I've got that old hopeless feeling.

What you are seeing is the result of m.o sending .dmg as application/x-apple-diskimage, a type that someone (possibly Apache) just made up, that OS X doesn't particularly recognize. Apple themselves send .dmg as application/octet-stream, which gives your "Format: Binary," but because of bug 318199, where Safari sniffs the content of application/octet-stream, and thinks our .dmg is text/html which it ought to display, m.o can't use that.

So unless there's some way Firefox can fake out the OS X filepicker, we're stuck.
Component: General → File Handling
QA Contact: general → file.handling
(Reporter)

Comment 7

12 years ago
Phil: both Tomcat and I see this on Windows too, so the problem appears to not just be confined to Mac.

(In reply to comment #6)
> I've got that old hopeless feeling.
> 
> What you are seeing is the result of m.o sending .dmg as
> application/x-apple-diskimage, a type that someone (possibly Apache) just made
> up, that OS X doesn't particularly recognize. Apple themselves send .dmg as
> application/octet-stream, which gives your "Format: Binary," but because of bug
> 318199, where Safari sniffs the content of application/octet-stream, and thinks
> our .dmg is text/html which it ought to display, m.o can't use that.
> 
> So unless there's some way Firefox can fake out the OS X filepicker, we're
> stuck.
> 

Hardware: PC → Macintosh

Comment 8

a year ago
I did some digging to find dmgs that would be served as application/x-apple-diskimage. Luckily I found Angband's downloads, which are just a directory index: http://rephial.org/downloads/3.1/

macOS 10.12.2 and FF 50.1 now correctly recognize the dmg! Closing as WFM.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.