Cache nodeinfos in the html content sinks

RESOLVED DUPLICATE of bug 355433

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 355433
12 years ago
12 years ago

People

(Reporter: sicking, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Right now we for each node we create convert tag-id -> atom -> nodeinfo. The first conversion there is an array lookup, the second is a hash lookup. However it would be easy to just add a lazily initialized cache that just maps tag-id directly to nodeinfo. That will save us a hash lookup and a bunch of virtual calls.

Patch comming up.

*** This bug has been marked as a duplicate of 355433 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.