LDAP does not correctly interpret LDIF format

RESOLVED DUPLICATE of bug 241220

Status

Thunderbird
Address Book
RESOLVED DUPLICATE of bug 241220
12 years ago
10 years ago

People

(Reporter: Karl Lattimer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.6) Gecko/20060808 Fedora/1.5.0.6-3 Firefox/1.5.0.6 pango-text
Build Identifier: 1.5.0.7

The LDIF format specifies that displayName and commonName are two separate entities in the schema, thunderbird interprets commonName as displayName even when a displayName is present in the LDIF information returned by the server. This behaviour is incorrect and should interpret displayName as displayName when present

Reproducible: Always

Steps to Reproduce:
1. View an ldif entry in the address card with the ldif entity displayName set
Actual Results:  
commonName is displayed in the displayName field, which should be displayed in its own commonName field.

Expected Results:  
displayName in the ldif should be represented by thunderbird as displayName and commonName should be represented as commonName

Updated

10 years ago
Assignee: mscott → nobody
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → DUPLICATE
Version: unspecified → Trunk
Duplicate of bug: 241220
You need to log in before you can comment on or make changes to this bug.