Firefox not starting with the Talkback extension enabled

RESOLVED FIXED

Status

()

--
critical
RESOLVED FIXED
12 years ago
9 years ago

People

(Reporter: Ehsan, Unassigned)

Tracking

({crash})

2.0 Branch
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20060918 Firefox/2.0 XpcomViewer/0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20060918 Firefox/2.0 XpcomViewer/0.9

I used the windowsupdate.com site to install a number of non-critical updates
(most of them for hardware such as WLAN card, modem, mouse, touchpad, etc.),
and I was prompted to restart the computer.  After the restart, Firefox wouldn't start.  Each attempt at starting Firefox would lead the firefox.exe process to terminate almost immediately, *without* causing a crash.  So, unfortunately, there are no talkback IDs to report.  Check out bug #355594 which is a similar problem on the same machine and at the same time happening with Thunderbird as well.

Reproducible: Always

Steps to Reproduce:
1. Try to start Firefox.
2. Watch nothing happening (because the process is silently terminating.)
3. Start Firefox in Safe Mode.
4. Disable the Talkback extension.
5. Close Firefox.
6. Start Firefox in normal mode.
7. Watch the browser open fine.
8. Enable the Talkback extension.
9. Restart Firefox.
10. Watch nothing happening (like before.)

I could go on and on with the same procedure.




about:buildconfig

Build platform
target
i586-pc-msvc

Build tools
Compiler 	Version 	Compiler flags
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TC -nologo -W3 -Gy -Fd$(PDBFILE)
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TP -nologo -W3 -Gy -Fd$(PDBFILE)

Configure arguments
--enable-application=browser --enable-update-channel=release --enable-official-branding --enable-optimize --disable-debug --disable-tests --enable-static --disable-shared --enable-svg --enable-canvas --enable-update-packaging
(Reporter)

Comment 1

12 years ago
If it matters, I have SeaMonkey "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060729 SeaMonkey/1.0.4" installed, and this problem doesn't seem to affect it.

Comment 2

12 years ago
What is happening if you disable your other extensions, but let Talkback be enabled?
(Reporter)

Comment 3

12 years ago
(In reply to comment #2)
> What is happening if you disable your other extensions, but let Talkback be
> enabled?

As long as Talkback is enabled, the problem shows again (I've tried it with no other extensions enabled, as well as with individual extensions enabled.)

(Reporter)

Comment 4

12 years ago
I have observed the same problem in Firefox 3 alpha 1, and the trunk's nightly build.  Disabling the Talkback extension did solve the startup issue in these cases as well.

FWIW, there's a forum discussion <http://forums.mozillazine.org/viewtopic.php?p=2649628>.
(Reporter)

Updated

12 years ago
Keywords: crash
Version: 2.0 Branch → Trunk

Comment 5

11 years ago
Ehsan, Does this also fail for you with current trunk?  (which uses breakpad instead of talkback)

cc: Carsten how commented in bug 349871
(Reporter)

Comment 6

11 years ago
(In reply to comment #5)
> Ehsan, Does this also fail for you with current trunk?  (which uses breakpad
> instead of talkback)

Nope.  I used to observe this problem on trunk when it used Talkback.  (I used to do my development on trunk with the Talkback extension disabled).  As soon as Breakpad was activated on the trunk, this problem no longer happens on trunk.  Updating the product version number of this bug.

> cc: Carsten how commented in bug 349871

FWIW, and just to reiterate: I observed this on a normal 32-bit XP Home installation (not x64).  And of course, since Talkback seemed to be the crasher itself, I could never get a Talkback ID for the crash!  :-)
Version: Trunk → 2.0 Branch
Fixed by the removal of Talkback.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.