download manager shows incorrect percentage of files downloading

RESOLVED INCOMPLETE

Status

()

--
enhancement
RESOLVED INCOMPLETE
12 years ago
10 years ago

People

(Reporter: junkforbrandon, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

when download manager is downloading multiple files the percentage completed only includes the files currently downloading, not the ones in queue. This is misleading if you are downloading lets say 20 files but they only download two at a time. Instead of the percentage starting at 0% and completing at 100% when the files are finished they only show the percentage completed of the current download.

Reproducible: Always

Steps to Reproduce:
1. find a site with multiple large files
2. start download of multiple large files so files start to be set in a queue.
3. download percentage only follows current download instead of total download

Actual Results:  
files download but percentage completed is misleading

Expected Results:  
download manager should show the percentage complete for ALL files including the queue.

Comment 1

12 years ago
Reporter, this was fixed in Firefox 1.5, which was released almost a year ago. Please upgrade.

*** This bug has been marked as a duplicate of 239006 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Jo, actually, this is a different problem than the one in bug 239006. Bug 239006 was about how the overall download progress was computed (i.e. 90% of 1k file and 10% of a 1 GB file is not 50% of two files), this one is about what files are considered for the calculation (currently downloading vs those in the queue).

Not a duplicate, reopening.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
On the other hand, as we don't know the size of files in the queue until we start downloading them, this bug may be considered INVALID or WONTFIX, but I'll leave this decision to the others.
Duplicate of this bug: 374393
Resolving old UNCONFIRMED Download Manager bugs as INCOMPLETE.  If you still see this issue, please reopen.

To mark all these bug changes as read, filter on ONOMATOPOEIA.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago11 years ago
Resolution: --- → INCOMPLETE
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.