Closed Bug 355874 Opened 14 years ago Closed 13 years ago

colors for categories with illegal chars do not work

Categories

(Calendar :: Calendar Views, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: pavel.zahradnik, Unassigned)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.8.0.7) Gecko/20060909 Firefox/1.5.0.7

It seems colors do not work for categories with some special characters in their name (Sunbird 0.3 RC2).

Reproducible: Always

Steps to Reproduce:
1. In the settings create a new category named "Vэroин" (it means "Anniversary" in the Czech language) and set its color to green.
2. Create a new event and set its category to "Vэroин".

Actual Results:  
The category of the created event is "Vэroин" but it has no color frame.

Expected Results:  
The created event should have green frame as its category is "Vэroин".
I can not reproduce this on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061006 Sunbird/0.3

I tried it with your "Výroèí" category and with a category called "Töstü" (artificial word).
Summary: colors for some categories do now work → colors for some categories do not work
Well it works with "Töstü" and also for example with "Prázdniny" (it means "Vacation" in the Czech language) but perhaps its more specific bug - it does not work with other characters like "ý", "è" etc. which are frequently used in the Czech alphabet (see http://en.wikipedia.org/wiki/Czech_alphabet).
(In reply to comment #2)
Just to add I am testing this with new profile in Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.9a1) Gecko/20061006 Sunbird/0.3

(In reply to comment #0)

> Steps to Reproduce:
> 1. In the settings create a new category named "Výroèí" (it means "Anniversary"
> in the Czech language) and set its color to green.
> 2. Create a new event and set its category to "Výroèí".
> 
> Actual Results:  
> The category of the created event is "Výroèí" but it has no color frame.
> 
> Expected Results:  
> The created event should have green frame as its category is "Výroèí".
> 

I can confirm it with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061027 Calendar/0.4a1
I selected timezone: Europe/Prague

Error:
Warning: Found unclosed string '"výro'.  Expected identifier or string for value in attribute selector but found '"výro'.  Ruleset ignored due to bad selector.
Source File: chrome://calendar/content/calendar-view-bindings.css
Line: 0
Warning: Unexpected end of file while searching for closing } of invalid rule set.
Source File: chrome://calendar/content/calendar-view-bindings.css
Line: 0
Error: [Exception... "An invalid or illegal string was specified"  code: "12" nsresult: "0x8053000c (NS_ERROR_DOM_SYNTAX_ERR)"  location: "chrome://calendar/content/calendar-views.js Line: 263"]
Source File: chrome://calendar/content/calendar-views.js
Line: 263
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061030 Calendar/0.4a1

Could confirm bug. Important: Could only confirm for ALL DAY EVENTS, not for "normal events"

NOT with:
-Výroèí
-ßäöüÄÖÜ (all German specials)

but with:
AÁBCČDĎEÉĚFGHChIÍJKLMNŇOÓPQRŘSŠTŤUÚŮVWXYÝZŽ (All Czech specials)
e.g. the test with Č only also produced the error

In my tests cases the error was not related to a time zone.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 393160
Bug is confirmed. If you create event and set category with name on Russian that event has no color frame. Tested on Linghtning and Sunbird 0.7 (Windows and Mac OS X)
Patch just submitted for bug 321010 (part1: illegal chars) should fix this.
Depends on: 321010
Fixed by patch from bug 321010 (see comment#9).
Status: NEW → RESOLVED
Closed: 13 years ago
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → FIXED
Summary: colors for some categories do not work → colors for categories with illegal chars do not work
Verified using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13pre)
Gecko/20080213 Lightning/0.8pre (2008021319) Thunderbird/2.0.0.13pre.
Status: RESOLVED → VERIFIED
Target Milestone: --- → 0.8
You need to log in before you can comment on or make changes to this bug.