Close only in Tab hinders productivity.

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
--
minor
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: Lars Schöning, Unassigned)

Tracking

2.0 Branch
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1) Gecko/20061003 Firefox/2.0
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1) Gecko/20061003 Firefox/2.0

In order to close a number of tabs, with the close button within the tabs it is hard to close a large number of tabs because:

1. If the tab space is resized it will mean that the close button of the next (unclosed) tab will not be directly below the mouse anymore.
2. If the rightmost tab is closed that will move to the second tab from the right. Also in this case the mouse will have to be moved.

I understand that the close button on the tab increases the usability of those who are not using Firefox professionally. However not having a universal tab-close button will hinder the productivity of all those who use it intensively.

My suggestion therefore is an additional (maybe optional) close button which will be left of the "list all tabs" button, but between the arrow and "list all tabs" button if the arrow button is shown.

Reproducible: Always
Modifying OS and Version
OS: Mac OS X 10.4 → All
Version: unspecified → 2.0 Branch
To restore the former behaviour you can set the value of the pref browser.tabs.closeButtons to 3.
http://kb.mozillazine.org/About:config
You can't have close buttons both on the tabs + on the tab bar however.
Maybe something for an extension?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.