using tab to move between fields causes crash

VERIFIED DUPLICATE of bug 34605

Status

()

Core
Layout: Form Controls
P3
normal
VERIFIED DUPLICATE of bug 34605
18 years ago
18 years ago

People

(Reporter: Luis Villa, Assigned: rods (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; I; Linux 2.2.14 i686; Nav)
BuildID:    2000041008

When using the tab key to move between fields, the latest builds (dating back a
week or so) will crash. Very simple bug- just pick a field, hit the tab key, and
watch the browser disappear.

Reproducible: The above should be "very nearly every time." Experimenting on
bugzilla, I saw it 19 out of 20 times, and on other pages it is absolutely
reproducible.
Steps to Reproduce:
1. Go to the top of this page- pick a field, any field.
2. Try to use tab to move to another field.

Actual Results:  Boom. Browser dies. 

Expected Results:  Should move to the next field.

Additional info:
1) Tested on both the latest Debian and RedHat versions, and SMP and non-SMP
machines.
2) This appears to be very similar to <a
href="http://bugzilla.mozilla.org/show_bug.cgi?id=20942">bug 20942</a> and I in
fact filed this as an attachment to that bug a few days ago. However, there has
been no motion on it since, so I figured I'd file it again as a new bug in case
the appropriate people have left mozilla or are occupied for some other reason. 
3) This occurs not just in pages with multiple fields but also on pages with a
single field. Don't know if that will help.

Comment 1

18 years ago
This is a dup of a smoketest blocker that has been fixed 4/10.

*** This bug has been marked as a duplicate of 34605 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
verify dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.