"Save Image As" attempts to redownload image.

RESOLVED DUPLICATE of bug 120809

Status

()

Firefox
Menus
RESOLVED DUPLICATE of bug 120809
12 years ago
10 years ago

People

(Reporter: jdagost1, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061003 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061003 Firefox/2.0

Using "Save Image As" from the right-click menu (or "Save Page As" when the current tab is only an image file) attempts to re-download the image, even if it is already fully loaded, instead of using the already-loaded image from cache. This wastes bandwidth and makes it impossible to download images from certain sites, such as Rapidshare, that use download tickets and such.

Reproducible: Always

Steps to Reproduce:
1) Go to any page with an image on it. The following is on Rapidshare and is good for demonstrating this bug due to its download ticket system. http://rapidshare.de/files/35351148/Sonic_Adventure_2_-_B.jpg.html

2) Load up the image completely, right-click, and hit "Save Image As" (or go into the File menu and click "Save Page As", this has the same effect).

3) Observe that Firefox attempts to redownload the image and instead downloads the "Invalid/Expired Download Ticket" page instead, a much smaller file.


Expected Results:  
Firefox should have just used the already-downloaded image that was being displayed in the tab.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061006 Minefield/3.0a1

When I click on a thumbnail on the given URL I get a new page. When I right click on one of the images on this page and choose "Save Image As" no new connections are made in my firewall. 

*** This bug has been marked as a duplicate of 302792 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

12 years ago
What thumbnail? That site isn't a thumbnail-type gallery. Did you accidentally post in the wrong bug report?
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 120809
You need to log in before you can comment on or make changes to this bug.