If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Command+click on a link on Yahoo! opens a new tab in Safari, why not Camino?

RESOLVED WORKSFORME

Status

()

Core
General
--
minor
RESOLVED WORKSFORME
11 years ago
2 years ago

People

(Reporter: Mike, Unassigned)

Tracking

Trunk
All
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.7) Gecko/20060911 Camino/1.0.3
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.7) Gecko/20060911 Camino/1.0.3

I read your response to other users' complaints regarding Camino's inability to open a Yahoo.com link in a new tab with Command+click, stating it was Yahoo's fault and invalid.  Safari has no problem doing this, however...   Why the disparity?

Reproducible: Always



Expected Results:  
Work as well as Safari.

Comment 1

11 years ago
Can you give full information in this bug? Which link should I click to see the bug?

Comment 2

11 years ago
A link to this response would be nice too.

Comment 3

11 years ago
Assuming the new Y! layout.
Applies to *any* link on that page.
Fails in Camino trunk, Firefox 2.0 RC2 and recent Minefield.
(and Fx 2.0RC2 spoofed as Fx 1.5).

Apparently some JS is catching the command+click event.
Middle-click works correctly (my mouse is set for it).

Apart from a few zillion of css errors, the Fx Error-Console doesn't report anything wrong.

Comment 4

11 years ago
(In reply to comment #3)
> Assuming the new Y! layout.
> Applies to *any* link on that page.
> Fails in Camino trunk, Firefox 2.0 RC2 and recent Minefield.
> (and Fx 2.0RC2 spoofed as Fx 1.5).

Absent any other information, the above sure sounds like Tech Evangelism to me.

Comment 5

11 years ago
(In reply to comment #4)
> Absent any other information, the above sure sounds like Tech Evangelism to me.
> 

It _could_ be a bug in Gecko's JS handling. As you can see from the source code, there is lots of JS in there, and it is not the most easy to read. Any JS specialist in the house ?

So far I've narrowed it down to this:
http://us.js2.yimg.com/us.js.yimg.com/i/ww/sp/js_1.9.14.js
Delete that _linked_ script, and command clicking on links works.
Have fun to debug that one.
(saving the page locally, and deleting things from the bottom upwards).

Comment 6

11 years ago
Created attachment 241692 [details]
testcase

One link on the page, and the script mentioned in comment 5 linked.
Command click fails.

BTW this works as expected in Safari 2.0 and latest Webkit nightly. It works correctly in Opera 9.02.

Comment 7

11 years ago
> One link on the page, and the script mentioned in comment 5 linked.
> Command click fails.

Commenting out line 197 (the line starting with var sUrl='http:) from the script will make the Cmd-click work.

Comment 8

11 years ago
(In reply to comment #3)
> Fails in Camino trunk, Firefox 2.0 RC2 and recent Minefield.
> (and Fx 2.0RC2 spoofed as Fx 1.5).

-> Core
Assignee: nobody → general
Component: Tabbed Browsing → JavaScript Engine
Product: Camino → Core
QA Contact: tabbed.browsing → general
Version: unspecified → Trunk
That's not a reduced testcase -- http://us.js2.yimg.com/us.js.yimg.com/i/ww/sp/js_1.9.14.js needs to be reduced.

Bugs like this should be left in a general component, not reassigned to the JS engine, unless there is specific evidence implicating the JS engine.  There is no such evidence yet.

/be
Does this happen on the 1.8.0 branch?
Assignee: general → nobody
Component: JavaScript Engine → General
QA Contact: general → general
Keywords: qawanted
Comment on attachment 241692 [details]
testcase

Ctrl+Click works for me, in recent 1.8 branch and trunk Firefox builds on Windows. I can't reduce a testcase for something I can't reproduce :)
Attachment #241692 - Attachment description: reduced testcase → testcase
Though if you can confirm that this bug is Mac specific, I can probably borrow a mac for long enough to debug a bit. If this is a regression, finding a narrow regression range would be ideal. Otherwise, I suspect this is an issue with the site's JavaScript, and not with Gecko.

Comment 13

11 years ago
> Does this happen on the 1.8.0 branch?

Yes, tested with Camino 1.0.3
(In reply to comment #12)
> Though if you can confirm that this bug is Mac specific, I can probably borrow
> a mac for long enough to debug a bit. If this is a regression, finding a narrow
> regression range would be ideal. Otherwise, I suspect this is an issue with the
> site's JavaScript, and not with Gecko.

I can confirm that I see this bug in Fx2 RC2 on Mac, but not Fx2 RC2 on Windows. (I haven't checked Linux, however.)
Does still not work with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b4pre) Gecko/20090413 Shiretoko/3.5b4pre ID:20090413031313

Martijn, is there an easy way to reduce this huge js file?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase-wanted
Hardware: PowerPC → All
Ah, and there is one error shown in the Error Console:

Error: YAHOO is not defined
Source File: http://us.js2.yimg.com/us.js.yimg.com/i/ww/sp/js_1.9.14.js
Line: 72
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:25.0) Gecko/20100101 Firefox/25.0
Build ID: 20130805030205

I can't reproduce this issue on the latest Nightly. Setting the status of this issue to Resolved Worksforme. If anyone else is still able to reproduce this issue, please reopen.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
Keywords: testcase-wanted
You need to log in before you can comment on or make changes to this bug.