All users were logged out of Bugzilla on October 13th, 2018

Firefox hangs when no Reason-Phrase is present in an HTTP response

RESOLVED INVALID

Status

()

RESOLVED INVALID
12 years ago
3 years ago

People

(Reporter: gerrard.jones, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; InfoPath.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727)
Build Identifier: Firefox Version 1.5.0.7

Firefox hangs when it receives an HTTP response which is missing a Reason-Phrase. For example, when Firefox gets an HTTP response with the status code '304', but the normal Reason-Phrase 'NOT MODIFIED' is missing and there is no other text in it's place. Sometimes Firefox handles this fine. Other times, it hangs for quite a while, or it actually displays the raw HTML code to the user.
I discovered this bug whilst browsing Sharepoint with Firefox. Microsoft have accepted that this is an HTTP error from Sharepoint and so it is not really Firefox's fault, but it could handle this error more gracefully.

Reproducible: Sometimes

Steps to Reproduce:
1. Setup a website which ouputs incorrect HTTP resonses in the manner described above. The easiest way I know to do this is by browsing to a Sharepoint based website, going to site settings and apply theme to site.
2. Navigate around this site for a few minutes. Refreshing pages seems to be the most effective way of reproducing this problem
3.

Actual Results:  
Somteimes the page works fine.
Sometimes it hangs and takes a long time to load a page which should already a file which should already be cached.
Other times raw HTML code is dumped on the screen.

Expected Results:  
The browser should either report this HTTP error as an error and load the remainder of the page, or else it should handle this error and load the file correctly.

Here is an example HTTP response which has caused this error.

HTTP/1.1 304
Date: Mon, 09 Oct 2006 10:27:38 GMT
Server: Microsoft-IIS/6.0
MicrosoftSharePointTeamServices: 6.0.2.5530
X-Powered-By: ASP.NET
Cache-Control: private
Content-Length: 16
Public-Extension: http://schemas.microsoft.com/repl-2
Component: General → Networking: HTTP
Product: Firefox → Core
QA Contact: general → networking.http
Version: unspecified → Trunk
sometimes it realizes it is invalid, sometimes it treats it as http 0.9
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.