Last Comment Bug 356021 - Unifinder and Task View empty when using CalDav Calendar
: Unifinder and Task View empty when using CalDav Calendar
Status: RESOLVED WORKSFORME
: regression
Product: Calendar
Classification: Client Software
Component: Provider: CalDAV (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-09 06:42 PDT by Sebastian Schwieger
Modified: 2008-04-17 07:27 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Sebastian Schwieger 2006-10-09 06:42:36 PDT
When using an older profile (in my case it was used at maximum two weeks ago, possibly less earlier), Sunbird does not show any tasks in task view and any events in unifinder. This probably causes several bug reports of the last days. e.g.: bug 356000 (VTODOS part), and bug 353703.

Steps to reproduce:
No steps to reproduce at the moment.

Result: empty unifinder and empty tasks view

When changing a task there occures an error:
Fehler: tree.taskView has no properties
Quelldatei: chrome://calendar/content/unifinderToDo.js
Zeile: 648

When adding an event there occures an error:
Fehler: SearchTree.eventView has no properties
Quelldatei: chrome://calendar/content/unifinder.js
Zeile: 105


tested with: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9a1) Gecko/20061006 Sunbird/0.3
Comment 1 Sebastian Schwieger 2006-10-09 07:45:02 PDT
I found the reason for the above behaviour:

I was subscribed to a Cosmo Caldav Calendar.

unchecking this Calendar in the calendar tab results in filled unifinder and task view.

this was introduced during 20060926 (works) and 20060928 (fails) builds.

So this probably turns out to be a duplicate of bug 355270 ? Opinions?
Comment 2 Sebastian Schwieger 2006-10-09 08:04:11 PDT
Besides Unifinder and Taskview not working for *all* calendars, the events and tasks of the CalDav calendar is not even shown in the main views. The Cosmo log gives a response code 401 and 207.

After several reproducible tests with new profiles, everything is now working. I do not know yet, why. There was a server restart before the bug occured. Could this be a reason? 
Comment 3 Bruno Browning 2006-10-15 18:38:58 PDT
I was able to reproduce this by running Sunbird 0.3 using a profile containing a calendar pointing at a Cosmo server that was not running. So I'm thinking this is most likely a duplicate of bug #328618
Comment 4 Sebastian Schwieger 2006-10-15 23:02:35 PDT
(In reply to comment #3)
> I was able to reproduce this by running Sunbird 0.3 using a profile containing
> a calendar pointing at a Cosmo server that was not running. So I'm thinking
> this is most likely a duplicate of bug #328618
> 
Definitely not, because I got server response codes (see comment 2).
Comment 5 Bruno Browning 2006-10-16 10:22:48 PDT
Apologies if I was unclear: I did not mean to imply that your Cosmo instance was not running. As you mention, it is logging responses that sound quite normal. My thought was that Sunbird shows the same errors as you were observing when there is no server response at all. This sounds to me like Sunbird had a problem correctly constructing the (client-side) calendar object, and did not report that problem, which is I think the point of bug 328618. I think a connection with bug 355270 is less likely, as the reporter of that bug does not mention the tree errors you report, and almost certainly would have.
Comment 6 Simon Paquet [:sipaq] 2007-09-08 05:53:21 PDT
Bruno, is this bug still occurring and does it still warrant a release note?
Comment 7 Bruno Browning 2007-09-08 10:12:39 PDT
I don't think this needs a release note. I've never been able to reproduce it other than as described in comment #3; did not WFM it because it could have been caused caused by a difference between Sebo's setup and mine (e.g. proxy, issues,  which I do think we need to relnote). On re-reading this bug I'm wondering if it wasn't an instance of bug 385916, which is now fixed.
Comment 8 Simon Paquet [:sipaq] 2007-09-08 10:50:48 PDT
Ok, I'm removing the relnote keyword, but leaving the decision to WFM this bug to you, Bruno. Can you please also send me a mail detailing what you would like in the release notes? Thanks.
Comment 9 Bruno Browning 2007-11-03 15:26:50 PDT
I haven't seen anything like this in ages, so I'm going to WFM it. Sebo, please re-open if you think that useful.

--> WORKSFORME
Comment 10 franjb68 2008-04-15 02:35:21 PDT
I'm having this problem with Thunderbird 2.0.0.12 and Lightning 0.8.

I've got the extension installed as a global extension, in the Thunderbird/extensions directory. That directory is read only.

Everything worked fine 'til I subscribed to some Google public ICS Calendars. If some ICS Calendar is checked, the Unifinder stops working. Unchecking the Calendar the Unifinder works again.

With tasks, if there is a ICS Calendar checked I can't see any task. If I uncheck the ICS Calendar and restart Thunderbird then tasks are shown.

The error console shows the following warning:
Warning: nsIInterfaceRequestor requesting invalid interface {a63f70c0-148b-11d3-9333-00104ba0fd40}

And the following errors:

Error: [Exception... "'Component does not have requested interface' when calling method: [nsIInterfaceRequestor::getInterface]"  nsresult: "0x80004002 (NS_NOINTERFACE)"  location: "<unknown>"  data: no]

Error: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIHttpChannel.responseStatus]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: file:///C:/apli/thunderbird2/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calICSCalendar.js :: anonymous :: line 849"  data: no]
Archivo de origen: file:///C:/apli/thunderbird2/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calICSCalendar.js
Línea: 849
Comment 11 Philipp Kewisch [:Fallen] 2008-04-16 23:48:01 PDT
The error console shows the following warning:
Warning: nsIInterfaceRequestor requesting invalid interface
{a63f70c0-148b-11d3-9333-00104ba0fd40}

The above error looks more like a warning from the provider for Google Calendar. Looks like I'm missing the nsIPrompt interface. I was aware of this, but only noticed shortly after release. Please file a bug in Provider: GData. 


Apart from the fact that this bug is closed, this bug is about the caldav provider, but you note you are using an ICS calendar. Please file a new bug or look for an existing bug in the ICS provider component.
Comment 12 franjb68 2008-04-17 07:27:12 PDT
I've found that all my problems with unifinder and tasks are gone by setting a manual proxy for Thunderbird, not the automatic configuration that I had.

So maybe this error is related with https://bugzilla.mozilla.org/show_bug.cgi?id=338527

Note You need to log in before you can comment on or make changes to this bug.