Can't copy from/paste to File input textfields using mouse

RESOLVED INVALID

Status

()

defect
RESOLVED INVALID
13 years ago
6 years ago

People

(Reporter: hhschwab, Unassigned)

Tracking

1.8 Branch
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.0.8pre) Gecko/20061009 Firefox/1.5.0.8pre
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1) Gecko/20061009 BonEcho/2.0
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1) Gecko/20061009 SeaMonkey/1.1b

I can cut/copy from or paste to a file input using the key commands, Ctrl+X, Ctrl+C, Ctrl+V.
I can set an cursor or select the text in it, but I can't copy&paste using the mouse. The moment I right-click, the focus is lost. I assume that's this bug.
Probably not worth trying to do anything, since we're trying to eliminate that textfield anyway....
Duplicate of this bug: 412766

Comment 3

11 years ago
Why do you want to remove that field? Using the browse button and the File
Upload dialog is so awkward (especially with the strange autocompletion that is
in there currently).

I think, this dialog is a workaround for the missing paste functionality, not a
solution.

Updated

9 years ago
Duplicate of this bug: 545549
FWIW, you can now drag and drop a file.
With the new UI, users can't believe any more they can copy/paste in the field. Marking an INVALID.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.